INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Video Stuttering, Dropped Frames (fixed)  (Read 4486 times)

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Video Stuttering, Dropped Frames (fixed)
« on: April 21, 2018, 08:51:47 pm »

I'm having issues with Video Stuttering and Audio Drop outs on my 4K HTPC on my PJ as well.  Have not worked it out yet.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #1 on: April 22, 2018, 01:56:57 am »

This is going to be one for Hendrik I think, as I just can not narrow it down... but it appears to be related to having Bitstreaming on.  The setup giving me grief is a HTPC / 1070 Nvidia GPU --> Yami Receiver --> JVC X7500 running at UHD res.

At worst I get both dropped & repeat video frames at the same time and even the Audio can cut in and out.  At best it is fine.  MC23 on the same PC has no issue.  I've spent hours trying:
- Upgrading / Downgrading Video Drivers (NVidia)
- Different NVidia power settings
- Checked PC is is Power Mode
- Tried 3 Versions of the madVR Plugin (MC24 as shipped, the one working with MC23, the latest madVR from doom) - all identical settings (kept the settings.bin folder)
- Tried all sorts of madVR tweaks and even the default settings and the lowest settings I could make.
- Tried copying all the Plug In folders from MC23 to MC14
- It will also drop frames and audio with RO Std.
- It's worse with BD Menu mode but can still drop with Title Playback
- Tried lots of MC24 versions
- Toggled MC Settings on/off
- Rebuilt all missing Thumbnails

Oddly, it seemed to settle down after slowing working through the MC24 versions up till current one.  I'm now back to where I started with 24.0.17 and it is (currently) working fine with the exception that it will stutter if I turn on bitstreaming. 
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #2 on: April 22, 2018, 02:57:59 am »

I found I could get bitstreaming stable if I did some seeks (left right buttons) back and forward then it would be OK (for abit at least).  Also removed a -50ms I had to 24hz lipsync mode, no idea if it was better or not.
Logged
JRiver CEO Elect

eddyshere

  • Galactic Citizen
  • ****
  • Posts: 469
Re: Video Stuttering, Dropped Frames
« Reply #3 on: April 22, 2018, 04:03:43 am »

... but it appears to be related to having Bitstreaming on.

Noticed the same. Have a marantz 8805 hooked up. Stuttering get's a bit less when I select direct sound as bitstreaming source. the source AVR (wasapi) stutters most. It's not unwatchable though....
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: Video Stuttering, Dropped Frames
« Reply #4 on: April 22, 2018, 04:42:56 am »

Since you compare to MC23, it happens with all video playback, not just menus? Then please make a separate thread for that. :)
I just tried Menu Playback with Bitstreaming and it seems to be just fine for me.
Logged
~ nevcairiel
~ Author of LAV Filters

tls62dk

  • Galactic Citizen
  • ****
  • Posts: 406
Re: Video Stuttering, Dropped Frames
« Reply #5 on: April 22, 2018, 07:50:19 am »

I am seeing the same thing. MC23 works perfectly. MC24 with the exact same setting is dropping and repeating frames.

Both are 64bit versions and both are bitstreaming. I only play BD in title playback, no menus.
Logged

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1340
Re: Video Stuttering, Dropped Frames
« Reply #6 on: April 22, 2018, 10:34:26 am »

- Upgrading / Downgrading Video Drivers (NVidia)

Have you tried v388.59 ? I was having frame drops too with or without madvr. v388.59 seems to be the latest/only driver that plays without frame drops for me.
Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫRSS315HE-22■DIYSG Cube-12
•SPA300Dѫ15-PRX8S4■YSTSW215

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #7 on: April 22, 2018, 04:46:02 pm »

OK - here is my Side by Side test (I presume the following should get an identical setup of the instances on the same PC).
- I did an backup of MC23 and a restore of this in MC24. 
- I also copied the madVR settings.bin file from MC23's plug in folder to MC24's plug in folder.

Played a single std BD from a local library in Title Mode being pulled over the NW and veiwed the madVR stats for 3min.  After the initial startup Dropped / Repeated frames:
MC23 = No Dropped / Repeated frames & Queues did not move
MC24 = 24 Dropped / 25 Repeated frames & Queues moved a bit (never to 0 but never stable).  The Dropped/Repeated frames seem to happen together (eg it seems to Drop / Repeat a frame right after each other).

I've attached logs.

If it helps I can repeat on a UHD disc (these show more dramatic drops).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #8 on: April 22, 2018, 05:07:54 pm »

Looking at the logs,

MC24 had a heap of these + and - 50ms Drift corrections regularly during playback:
- Playback: COutputPluginAudioRenderer::DoRenderSample: Correcting drift by 49.693 ms
- Playback: COutputPluginAudioRenderer::DoRenderSample: Correcting drift by -49.719 ms

This may explain (or report) seeing both a Dropped & Repeated frames at almost the same time in the madVR gui.

MC23 had none of these during playback (but two at the initial playback start up).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #9 on: April 23, 2018, 04:04:57 pm »

Do you need any more tests, logs etc?
Logged
JRiver CEO Elect

mojave

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3732
  • Requires "iTunes or better" so I installed JRiver
Re: Video Stuttering, Dropped Frames
« Reply #10 on: April 23, 2018, 04:16:39 pm »

What do your madVR stats say for your present queue? If it isn't filling up, then I've found that Windows Defender is the problem. Have you added exclusions for MC24 yet? I've had the same issue (HTPC > 1080Ti > JVC X9500 at 3820p) and temporarily turning off Windows Defender fixes the issue. 
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #11 on: April 23, 2018, 05:28:10 pm »

Check the firewall & turned it on/off, added MC24.  Even then copied the rip to the local HDD to be sure.  Same thing.  Lots of these + and - 50ms Drift corrections even with the local playback.  FYI the Queues are full, then drop a bit (never to 0) when the Dropped & Repeated frames happen.  I've already spent hours trying playing with the settings, but identical settings on MC23 are fine (unless I've missed something!).
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: Video Stuttering, Dropped Frames
« Reply #12 on: April 23, 2018, 05:34:41 pm »

If the audio renderer is actually correcting for drift, then something in the audio engine is probably calculating latency wrong. I wonder if there is something wrong from the sync play changes. You don't have that on, do you?
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #13 on: April 23, 2018, 05:41:09 pm »

Where is the option to turn on/off sync play?
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #14 on: April 23, 2018, 05:43:06 pm »

Do you mean A/V Sync Correction?  Then yes I have -50ms for 24hz

Edit: Retested it again with A/V Sync Correction set to 0.  No change, still seeing in the logs these dual + and - 50ms drift corrections
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: Video Stuttering, Dropped Frames
« Reply #15 on: April 23, 2018, 05:48:17 pm »

No, I mean sync play between zones. But nevermind that, I may have found something (which was losely related to that sync thing), so we're going to try that in the next build.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #16 on: April 23, 2018, 05:49:58 pm »

:)
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames
« Reply #17 on: April 24, 2018, 04:55:32 pm »

... I may have found something (which was losely related to that sync thing), so we're going to try that in the next build.

Looks like it's fixed.  No more + and - 50ms Sync Correction and playback is looking good (so far) without any Dropped and Repeated Frames

Thanks again
Nathan

(note: I got a test build from Bob for another issue but it looks like your changes made it into that version).
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: Video Stuttering, Dropped Frames
« Reply #18 on: April 24, 2018, 04:58:34 pm »

(note: I got a test build from Bob for another issue but it looks like your changes made it into that version).

And I was wondering how you got the fix, since there was no build yet. :p
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #19 on: April 24, 2018, 05:15:39 pm »

 ;D Could not wait that long to get back to testing UHD & Menus! 

Anyway, this bug is fixed!
Logged
JRiver CEO Elect

tls62dk

  • Galactic Citizen
  • ****
  • Posts: 406
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #20 on: April 25, 2018, 10:22:19 am »

Sounds good. Looking forward to the next release. This seems to be the only problem I have with MC24 so far.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #21 on: April 26, 2018, 03:43:21 pm »

MC24.0.19 is now posted
Logged
JRiver CEO Elect

rec head

  • Citizen of the Universe
  • *****
  • Posts: 1006
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #22 on: April 26, 2018, 03:56:08 pm »

Great news. I was trying to watch The Last Jedi a couple nights ago and kept reducing MadVR settings trying to get it to play without stuttering and dropping frames like crazy. Now I can go put my settings back.
Logged

cabu8803

  • Recent member
  • *
  • Posts: 29
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #23 on: April 27, 2018, 09:19:40 am »

I still have a lot of video and sound stuttering, but only when I start playing the BluRay with the BD Menu with Red October HQ (either with or without sound bitstream). I have no problems if playing with Red October Standard.

The Bluray I am having problems are produced by Inakustik. (I only have Concert in BluRay) that I have ripped to BDMV folders and place on my NAS

For reference I am having problems with this one: Mike Stern Band: New Morning - The Paris Concert

Regards
Logged

eddyshere

  • Galactic Citizen
  • ****
  • Posts: 469
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #24 on: April 27, 2018, 11:24:03 am »

I have the same problem with the Bluray of John Mayer Where the Light Is.

It happens with and without bitstreaming in Full Menu playback. It feels like the video would be in a kind of slow-motion.
Playing without menu support is OK

GPU is GTX1080 with nvidia drivers 397.31
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #25 on: April 27, 2018, 04:43:43 pm »

Thanks for the testing.  Since they work in RO, fo you mind trying this and see if it still occurs when in in ROHQ?:
- Delete all the folders in "C:\Users\[USERNAME]\AppData\Roaming\J River\Media Center 24\Plugins" (MC will re-download all the sub folders with default settings).  Note: If you have customised any madVR Settings you will want to save the "settings.bin" file and copy it back into the madvr folder later.

Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #26 on: April 27, 2018, 05:00:25 pm »

The other thing to check in ROHQ.  Can you bring up the madVR Stats (CTRL+J) and note what the "Movie xx.xxx fps" is)
- When the Menu is Playing
- When the main title is Playing (in Menu Mode)
- When the main title is Playing (in Title Mode)

I have also seen issues (eg Billy Lynn), where the main title is 59.94 but the Menu is 23.976.  When commencing playback in Menu Mode with AutoFrame Rate changing on, the discs starts playback in 23.976 using Menu Mode but does not change to 59.94 when the main title starts. 
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: Video Stuttering, Dropped Frames (fixed)
« Reply #27 on: April 27, 2018, 05:03:12 pm »

I have also seen an issues (eg Billy Lynn), where the main title is 59.94 but the Menu is 23.976.  When commencing playback in Menu Mode with AutoFrame Rate changing on, the discs starts playback in 23.976 using Menu Mode but does not change in 59.94 when the main title starts.

When using MCs refresh rate changer, it only uses the value from the FPS database field to select the rate - which is filled during file analysis in title playback mode, so most of the time it should match the main titles rate, anyway. If not, you can also fix that field.
Logged
~ nevcairiel
~ Author of LAV Filters
Pages: [1]   Go Up