INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problem with MC over DNLA: all songs are stopped after 5 seconds  (Read 4473 times)

Robin Hood

  • Recent member
  • *
  • Posts: 25

Hello, I'm new to this forum and I need some help with MC using DNLA: this worked finefor me during the last 2 years. Since 4 weeks, all songs (single or in a playlist) are stopped after 5 seconds, then MC skips to the next one wich is also stopped after 5 seconds and so on. This doesn't occur using the internal speakers of my laptop.

Anybody a clue what might go wrong?

Thanks a lot!

BTW: this occurs using MC21, MC22, MC23 and MC24.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71630
  • Where did I put my teeth?
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #1 on: May 12, 2018, 08:54:17 am »

Try the DLNA option called Setnextavtransport
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #2 on: May 12, 2018, 09:20:29 am »

Thanks for the swift reply. I'm using the German version.Could you by chance tell me where to find this option?
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #3 on: May 12, 2018, 10:58:43 am »

I just found the option Setnextavtransport, but there's no difference if activated or not. The renderer works fine, there's a second laptop where the problem dosn't occur.

Is there a way to reset all options in MC to default?
Logged

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #4 on: May 12, 2018, 05:02:21 pm »

Make sure you have the very latest build on MC installed.
Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #5 on: May 13, 2018, 04:49:13 am »

My actual version is 24.0.20 64 Bit.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7461
  • When Summer comes...
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2024 Update (24H2) 64-bit (Intel N305 Fanless NUC 32GB RAM/500GB M.2 NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | JBL 306P MkII Studio Monitors | Audio-Technica ATH-M50x Headphones

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #7 on: May 13, 2018, 05:26:52 am »

Thanks. But still the same Problem.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #8 on: May 15, 2018, 12:12:41 pm »

Maybe somebody can help me by interpreting the logfile?
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #9 on: May 16, 2018, 05:54:16 pm »

Have you tried deactivating your antivirus temporarily and then playing songs via DLNA? I noticed a reference to Kaspersky in your log file.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71630
  • Where did I put my teeth?
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #10 on: May 17, 2018, 06:42:04 am »

If you're using Kaspersky, uninstall it.  Disabling won't always work.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #11 on: May 17, 2018, 12:03:35 pm »

Kaspersky is uninstalled, same problem, log is attached.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71630
  • Where did I put my teeth?
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #12 on: May 17, 2018, 12:13:24 pm »

Any idea what these are?
http:
 //10.189.225.43:39093/Control/org.mpris.MediaPlayer2.mansion/RygelAVTransport

[Broken link is intentional]
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #13 on: May 17, 2018, 05:04:12 pm »

Any idea what these are?
http:
 //10.189.225.43:39093/Control/org.mpris.MediaPlayer2.mansion/RygelAVTransport

[Broken link is intentional]

These are links to Jongo speakers or to the desktop Mediaplayer2, which might explain the problem.
Logged

schama

  • Member
  • *
  • Posts: 1
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #14 on: May 18, 2018, 01:02:39 am »

That's correct. I'm using Pure Jongo A2 to stream to my receiver. This works correctly with MC on a second computer and on my mobile devices. So there's definitivly no problem with the Jongo. It would be very useful (I hope) to do a clean uninstall for MC and reinstall it. But after checking the options "delete all registry entries" and "all library data", my options in MC are still the same and all my library names and so on remain the same. So there cannot be a clean deinstallation. If I knew where all the configuration information are hidden, maybe that could help.   
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #15 on: May 18, 2018, 06:10:41 am »

What are the audio settings on the second computer which works correctly? Have you checked in device manager for any sound device problems (the dreaded exclamation mark) sometimes windows doesn't install the correct driver versions.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #16 on: May 18, 2018, 07:34:31 am »

What do you mean by audio settings? Settings in Windows or in MC. If in MC, which settings do you mean?
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #17 on: May 18, 2018, 08:32:58 am »

What output device is selected in MC on the computer which works?
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #18 on: May 18, 2018, 08:43:00 am »

It's the Jongo A2 appearing under "playing now". Same as on the computer with problems.
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #19 on: May 18, 2018, 09:06:21 am »

In MC go to Tools>Options>Audio there you will see the audio device being used by mc for output. Is it the same on both computers?
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #20 on: May 18, 2018, 10:08:43 am »

As I'm using a german version, there's no "tools". Could it be the red marked "Steuerung" (see attached screeshot)? And do youmean the "audiopath"?
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #21 on: May 18, 2018, 10:21:44 am »

Audiopath is the same on the working and the not working machine: "not using the JRiver audio engine".
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #22 on: May 18, 2018, 10:23:21 am »

One more information: there's no sound to be heard during the 5 seconds the songs are "played".
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #23 on: May 18, 2018, 10:57:18 am »

One more information: there's no sound to be heard during the 5 seconds the songs are "played".
What's the format of the tracks you are trying to play?
Check the configuration for MC's DLNA server on both the working and non-working MC's. Are they the same? Is there more than one DLNA server??
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #24 on: May 18, 2018, 11:02:26 am »

Steuerung = Controls so I guess it will be in there somewhere. Why not change language to English?

Just switched to German version and options is under the extras tab.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #25 on: May 18, 2018, 11:22:59 am »

Track format is mp3 at a bitrate of 160. I compared the configuration a couple of times and didn't find any differences.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #26 on: May 18, 2018, 12:05:06 pm »

Track format is mp3 at a bitrate of 160. I compared the configuration a couple of times and didn't find any differences.
Tell me what the audio configuration of the DLNA servers on both machines is set to please. (and do you have more than one configured on either machine?)
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #27 on: May 18, 2018, 12:31:37 pm »

Hi Bob, this is the DLNA configuration on both computers (screenshot).
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #28 on: May 18, 2018, 01:36:37 pm »

Hi Bob, this is the DLNA configuration on both computers (screenshot).
So it's doing conversion when necessary which will convert everything but mp3's.
I wonder if you are missing the encoder? MC downloads that when it's needed.
Look in the [username]\App Data\Roaming\J River\Media Center 24\Plugins\mp3_encoder

What version of windows (and architecture) are you running?
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #29 on: May 18, 2018, 03:42:27 pm »

Hi Bob, don't think that's his problem, his latest log shows a failure to play mp3 files.
This is a line from his log which may or may not be the cause of the failure to play.

0015266: 10588: Playback: CPlayerZoneDisplayInfo::UpdateFileInfo: Playback state is PLAYING but real TransportState is not. Estimated = 500, Duration = 258000
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #30 on: May 18, 2018, 03:56:43 pm »

Hi Bob, don't think that's his problem, his latest log shows a failure to play mp3 files.
This is a line from his log which may or may not be the cause of the failure to play.

0015266: 10588: Playback: CPlayerZoneDisplayInfo::UpdateFileInfo: Playback state is PLAYING but real TransportState is not. Estimated = 500, Duration = 258000
Actually that fits pretty well.
MC determines the duration in advance and it's not there since the conversion never happened.
I've been able to reproduce that in certain situations the encoder isn't downloaded, I'm not sure why and we are working on figuring it out.
In the meantime, it WILL be downloaded if he does:
Tools->Options->Encoding->Encoding For: File-Conversion and choose MP3. (edit, I incorrectly posted FLAC earlier).

I bet it works then.
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #31 on: May 18, 2018, 04:12:53 pm »

I bow to your superior knowledge Bob.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #32 on: May 19, 2018, 12:01:55 pm »

This is a screenshot of the directory you mentionned. There is no "plugins" in it.How can I solve that?
My computer is running Windows 10 64 Bit. BTW: thank you fore caring!

I will try your tips next week as I'm not at home currently. The explanations sound quiet reasonable  :)
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #33 on: May 21, 2018, 09:09:01 am »

This is a screenshot of the directory you mentionned. There is no "plugins" in it.How can I solve that?
My computer is running Windows 10 64 Bit. BTW: thank you fore caring!

I will try your tips next week as I'm not at home currently. The explanations sound quiet reasonable  :)
Just try what I suggested above:
In the meantime, it WILL be downloaded if he does:
Tools->Options->Encoding->Encoding For: File-Conversion and choose MP3. (edit, I incorrectly posted FLAC earlier).
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #34 on: May 21, 2018, 11:10:00 am »

These are my current configurations (changed manually). MC did indeed download and register the mp3 encoder. The problem still remains. If someone could provide me a link to the English version, I could try that one.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #35 on: May 21, 2018, 11:31:19 am »

Switch to English by doing Tools->Language.

The Settings that matter here are the ones in your second screen shot, Audio->Erweitert
Under Erweitert there is an entry of "Audio formats to convert".
Anything your renderer can't handle should be checked.
You can start by checking everything except for mp3 (which should be the default) and see if that works.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #36 on: May 21, 2018, 12:02:23 pm »

Hi Bob, sorry, I don't achieve nothing. Isn't the a possibility for a clean uninstall? My computer functionned pretty well without any adoption 'til 2 months ago. With the second one who works I didn't have to change any configurations at all. After each uninstall my options remain even if "clean all registry entries" is checked.
Logged

swiv3d

  • Guest
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #37 on: May 21, 2018, 12:05:21 pm »

When the German language is showing the way to change language is Extras>Sprache then select from the drop down list.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #38 on: May 21, 2018, 12:08:10 pm »

Thanks, that's already done. MC is in english now.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #39 on: May 21, 2018, 01:26:05 pm »

Different builds of MC can coexist with each other without issue so you wouldn't need to un-install MC24.

It's difficult to know what the issue is here, there aren't any huge changes in the DLNA code between MC23 and MC24.
Also we have a Jongo T2 that works fine.

I see in the log you are playing files from a Drive K:
what is K: exactly?

Also, the DLNA controller options for your Jongo zone are:

Ignore Transport Events
Disable SetNext Support
Ignore GetPosition Failure

Are any of those set?


Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #40 on: May 22, 2018, 01:25:35 am »

My wish to uninstall is nothing but a chance to start from scratch as until 2 months ago, all worked fine. The version 19 to 23 are producing the same problems.

K: is just a partition on my single Samsung SSD where 90 gb of tracks are stored.

Only the "Disable SetNext Support" is checked. But on the second machine with the working MC 24 not even this one is checked.

I will try this evening after work.
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #41 on: May 22, 2018, 10:34:25 am »

I just checked the other options as recommended - no difference.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13593
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #42 on: May 22, 2018, 01:53:54 pm »

My bad, I gave a linux answer.
When you remove MC24 on windows, it will give you the choice to remove the registry entries and library files.
Assuming you have no need of those or have a MC23 backup you should select both options.

Note that when you install MC24 again, it will pickup any existing MC23 registry entries and library files.
You can do the clear library function in MC to reset the library.

Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #43 on: May 23, 2018, 11:03:57 am »

I just solved the problems the hard way: restored an image of the systems partition  from march. All works fine now, even version 24. Thanks to all for trying to help!
Logged

milknkukis

  • Regular Member
  • World Citizen
  • ***
  • Posts: 112
  • Crumbs!
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #44 on: May 24, 2018, 01:56:56 pm »

I suspect your victory might be short-lived! Have you installed any Windows Updates yet? I'm still using MC23 but I have been having the same problem as you for the last couple of weeks. I also have several Jongo(s) and I  found I could no longer get MC through the Windows firewall. Disabling the Private firewall has enabled me to keep playing music but I can't find a way to create an exception that works to allow me to turn the firewall back on. Like you, this not a new setup, nothing has changed here for at least a year, I'm fairly certain it's a Windows change which has been my downfall.

The 5 second delay is probably about right, there is a considerable delay on the Jongo(s) when they start playing, it probably takes this long for MC to get the feedback that the device isn't responding. I have reported issues in the past which resulted in the team J River actually buying a Jongo (thanks guys) and I remember they were distinctly unimpressed with the hardware, I think because of this slow response time? It's a dead technology anyway now but it was a shame as it can do some nifty stuff when you have multiple devices.

Maybe this will help to shine more light on the issue? Good luck!
Mark
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #45 on: May 25, 2018, 12:58:33 am »

The big update is done and it still works fine. But the problems I encountered were before the update, in the end of march. Nevertheless, my Jongos were cheap (25 Euro each) and they are doing what they are meant for: serving my old stereo  :)
Logged

milknkukis

  • Regular Member
  • World Citizen
  • ***
  • Posts: 112
  • Crumbs!
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #46 on: May 25, 2018, 06:40:09 am »

Ah well, might not be the same issue then. I'll keep trying.

I have three A2's (Office, Living Room, Outside) and a T2 in the kitchen, what's really nice is how they sync themselves when playing from the Pure app. Now if I just get MC to drive all of them at once in perfect sync I'd be set!

PS. There is a useful 'bug' in the Jongo system, which means sometimes they all stay in sync and playing together when you stream music from MC to just one of them. If I could work out how to reproduce this reliably it would be great.

Glad you found a fix.
Mark
Logged

Robin Hood

  • Recent member
  • *
  • Posts: 25
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #47 on: May 25, 2018, 07:32:23 am »

Good luck to you and thanks for the tips on the A2s!
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71630
  • Where did I put my teeth?
Logged

musicmahn

  • Junior Woodchuck
  • **
  • Posts: 66
Re: Problem with MC over DNLA: all songs are stopped after 5 seconds
« Reply #49 on: October 31, 2019, 04:35:56 pm »

I'm having the same exact problem trying to use BubbleUPnP running on my NAS to stream to my Chromecast Audio.
It can also take an incredibly long time for the Chromecast to show up as well (like over 30 min)

The thing is I've had success with this in the past and made no changes.
I can even hear MC trigger the Chromecast as it makes a little noise when it connects

5 seconds of meh  :(
Logged
Pages: [1]   Go Up