INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: "Open GL renders failed to load"  (Read 1914 times)

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
"Open GL renders failed to load"
« on: February 25, 2019, 12:23:00 pm »

Since I started using MC24 I get that message on the second screen after two or three boots of the app. To fix it I need to delete the MC24 directory and re-install. Then it works for a few more boots. This is unique to MC24, previous versions back to MC19 were fine on the same hardware/OS.

What exactly does this message mean?

I'm game for upgrading to the newest version if that would help.


Win7pro/32
Nvidea FX3800
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71603
  • Where did I put my teeth?
Re: "Open GL renders failed to load"
« Reply #1 on: February 25, 2019, 02:28:24 pm »

Did you try updating MC?
Logged

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
Re: "Open GL renders failed to load"
« Reply #2 on: February 25, 2019, 05:00:23 pm »

The MC24 version that was around July 2018 seems to be the most reliable.

Do you mean updating to MC25? I'm willing to try that.
Logged

swiv3d

  • Guest
Re: "Open GL renders failed to load"
« Reply #3 on: February 25, 2019, 05:02:15 pm »

I think Jim meant updating to MC24.0.75.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7450
  • When Summer comes...
Re: "Open GL renders failed to load"
« Reply #4 on: February 25, 2019, 06:50:50 pm »

In a basic nutshell, newer MC builds use ANGLE for Theater View instead of OpenGL that older MC24 builds used (which older onboard graphics and older GPUs likely lack support for, hence the error you're getting). MC used to use Direct3D for Theater View but it was deprecated in favor of OpenGL, then updated to use OpenGL ES (ANGLE) instead for compatibility reasons. So using the latest MC24 build is likely the way to go.

This is what ANGLE is: https://github.com/google/angle
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2024 Update (24H2) 64-bit (Intel N305 Fanless NUC 32GB RAM/500GB M.2 NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | JBL 306P MkII Studio Monitors | Audio-Technica ATH-M50x Headphones

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
Re: "Open GL renders failed to load"
« Reply #5 on: February 25, 2019, 07:51:28 pm »

OK, I'll try MC24.0.75.

But is the new MC25 also an option?
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71603
  • Where did I put my teeth?
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10772
Re: "Open GL renders failed to load"
« Reply #7 on: February 26, 2019, 03:29:36 am »

This doesn't sound very logical to me. Something that works a few times and then just stops until you reinstall, sounds very bizarre. We don't actually modify anything anywhere, or do anything that would even remotely explain it.

If it still happens with 24.0.75, can you post a log file of when its broken?
https://wiki.jriver.com/index.php/Logging
Logged
~ nevcairiel
~ Author of LAV Filters

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
Re: "Open GL renders failed to load"
« Reply #8 on: March 10, 2019, 10:11:09 pm »

This doesn't sound very logical to me. Something that works a few times and then just stops until you reinstall, sounds very bizarre. We don't actually modify anything anywhere, or do anything that would even remotely explain it.

If it still happens with 24.0.75, can you post a log file of when its broken?
https://wiki.jriver.com/index.php/Logging

MC24.0.75 does not work at all. Here is what I did to create the log file:

1) Booted a working version of JRiver, MC24.0.41 and set the display to "Standard view" on Monitor #1.
2) Installed MC24.0.75
3) Boots properly into standard view on monitor #1. I eanbled logging to make a log file here.
4) select "Theater view" and monitor #2 displays the "Open GL Renders failed to load".
5) At that point the only choice seems to be to quite the program.

Again the video card is an Nvidia FX3800. I need this specific card because I output HDSDI (broadcast standard video) and not HDMI.

Where do I send the log file?

Thanks.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10772
Re: "Open GL renders failed to load"
« Reply #9 on: March 11, 2019, 04:42:54 am »

You can either attach it here, or mail it to hendrik at jriver dot com

Note: You should be able to exit out of Theater View even in the failed state by pressing Escape a few times.
Logged
~ nevcairiel
~ Author of LAV Filters

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
Re: "Open GL renders failed to load"
« Reply #10 on: March 11, 2019, 04:14:46 pm »

You can either attach it here, or mail it to hendrik at jriver dot com

Note: You should be able to exit out of Theater View even in the failed state by pressing Escape a few times.

Log attached. I'll try the escape next time.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10772
Re: "Open GL renders failed to load"
« Reply #11 on: March 11, 2019, 04:56:52 pm »

Your Log does not actually contain any log files, unfortunately.
Can you check to enable "Output to a log file" in Help -> Logging, then try to reproduce, and then make the log package?
Logged
~ nevcairiel
~ Author of LAV Filters

Glimmie

  • Junior Woodchuck
  • **
  • Posts: 51
Re: "Open GL renders failed to load"
« Reply #12 on: April 21, 2019, 07:38:10 pm »

Just a quick update and closure. I replaced he mother board with an exact same one. Wiped the HDD and installed Win7-64. Then installed MC25-64. Still using he Nvidia FX3800-SDI

Same problem! "Open GL Shaders Failed to Load".

But I then ran Windows update which installed 173 updates and after that MC25 booted and ran properly.

So we're good.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10772
Re: "Open GL renders failed to load"
« Reply #13 on: April 22, 2019, 01:50:40 am »

Installing updates is always good. Glad you got it solved!
Logged
~ nevcairiel
~ Author of LAV Filters
Pages: [1]   Go Up