Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Aeon Z-Stick Won't Work with RPi4 [Solved]  (Read 1643 times)


  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 70045
  • where the buffalo roam
Aeon Z-Stick Won't Work with RPi4 [Solved]
« on: November 18, 2019, 06:38:48 pm »

I had to buy a USB hub to get the white Z-Stick Gen5 to work with the new Raspberry Pi 4.  Bob found the solution:
This particular (cheap) hub will make the z-stick work on the pi4.
Not all hubs will work.
Problem thread here:

I had tried (unsuccessfully) to get it working with a different (powered) USB 3.0 hub.

Bob thinks it has to do with the USB2.0 - 3.0 negotiation failing.  It's a problem with the RPi4.

It's working now with Engen on the RPi4.  Thanks, Bob.

I backed up Engen to my phone from the old RPi3 and restored on the RPi4.  It worked perfectly.

The hub is called Onvian 3 Port USB Hub High Speed Splitter.  It has one USB 3.0 port and 2 USB 2.0 ports.  It's $9.
Pages: [1]   Go Up