INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Image Metadata XMP:Label tag missing ??  (Read 1758 times)

jmhdassen

  • Member
  • *
  • Posts: 3
Image Metadata XMP:Label tag missing ??
« on: May 26, 2021, 01:34:54 am »

I started using MC for music long time ago, but now I am also interested in using it for image display.
I use dedicated applications for Raw processing and Metadata editing. I do not want to do any editing in MC.
But I found that MC is just about the only application that lets me view my images on different devices. JRemote2 is clunky, but I can find my images. Panel is actually a lot better, but I wish there were more configuration options. Opportunities for improvement, but basic functionality is there.

But there is one big problem for me: I can not see that the XMP:Label tag (aka Color Label) gets loaded. It is present in my jpg files, but not in MC loaded images.
My workflow is pretty much dependent on color labels in existing images.

Is this tag really missing? or is it hidden somewhere? Configuration issue??
This tag is used in all other image applications I have seen, so I find it strange that I can not find it in MC.

I am using MC 27 on Ubuntu 20.04.

Thanks, JD
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71077
  • where the buffalo roam
Re: Image Metadata XMP:Label tag missing ??
« Reply #1 on: May 26, 2021, 07:21:16 am »

Make sure the server is not converting.

It's not clear whether you mean that it's missing on the server or on the remote.
Logged

jmhdassen

  • Member
  • *
  • Posts: 3
Re: Image Metadata XMP:Label tag missing ??
« Reply #2 on: May 26, 2021, 09:51:37 am »


It is not on the server........
If it is supposed to exist, then what is the Library Field for it?
Using XnView MP on the jpg, we can see the following information in the XMP group:



xmp   
CreateDate   2020-01-30T10:47:14+08:00   
CreatorTool   photools.com IMatch 20.7.0.4 (Windows)   
Label   Red   
MetadataDate   2020-08-03T12:36:04+07:00   
ModifyDate   2020-08-03T12:36:04+07:00   
Rating   1   

JD
Logged

jmhdassen

  • Member
  • *
  • Posts: 3
Re: Image Metadata XMP:Label tag missing ??
« Reply #3 on: May 26, 2021, 08:23:34 pm »

More information:

I did some more experimenting.
I think the problem is with the Tag() function. Specifically: which tags does the Tag() function recognize?
I did some experiments with Expressions in a view: Tag(tag name):
Tag(exif: ISO) works fine
Tag(exif: Camera) works fine
Tag(exif: Model) does NOT work
Tag(exif: Shutter Speed) works fine
Tag(exif: ShutterSpeedValue) does NOT work
Tag(xmp: Label) does NOT work
Tag(xmp: Rating) does NOT work

According to exiftool the image has the following metadata (a.o.):

[EXIF]          Model                           : NIKON Z 7
[EXIF]          ISO                              : 2200
[EXIF]          ShutterSpeedValue        : 1/125
[XMP]           Rating                          : 1
[XMP]           Label                            : Red


'Shutter Speed', 'ISO' and 'Camera' are the fields listed in the MC Predefined Library Fields.

So I suspect that the 'tags' that are recognized by the Tag() function are very limited and not very standard [exiftool follows standards fairly closely].
If that is the case then MC image is not really ready for metadata.

I think it would be good if we can have a function that extracts standard tags from an image. Never mind the Predefined Library list, we can always add custom names to the Library

Regards, JD

Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41808
  • Shoes gone again!
Re: Image Metadata XMP:Label tag missing ??
« Reply #4 on: June 02, 2021, 07:59:34 am »

Could you send a file with the metadata you're looking for to matt at jriver along with some instructions?  Thanks!
Logged
Matt Ashland, JRiver Media Center

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10828
  • Dogs of the world unite!
Re: Image Metadata XMP:Label tag missing ??
« Reply #5 on: June 07, 2021, 12:30:38 pm »

This will be in MC28:

NEW: Tag() expression function will return image XMP tags that are not JRiver database fields, for example, Tag(XMP: Label).  Also, Tag(EXIF: Make) and Tag(EXIF: Model) will return make and mode of the camera, individually (whereas [Camera] returns a combination of the two as before).
Logged
Yaobing Deng, JRiver Media Center
Pages: [1]   Go Up