INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2]   Go Down

Author Topic: Quick Start Guide for Installing JRiver Mediacenter 27 on an rPi4 2-4-8GB  (Read 14324 times)

Wheaten

  • Guest

I did write this for a reason:
Quote
•   Now we need to open a VNC session to the rPi. Don’t use Microsoft RDP as RDP can’t connect to a console session on Linux. We’ve already installed the VNC server, so we need a VNC Viewer, like “ultraVNC” (windows), or the built in VNC viewer on the MAC “Screen Sharing”.

JRiver did start up and is running, but you can't connect via windows RDP to the started console session on Linux. You need a VNC viewer for this.
RDP will create a new session. In this session MC didn't start, as this session did not boot the Pi. And JRiver started during the boot in the first session.
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313

It just dawned on me.....I have a wireless keyboard and mouse and a dongle is always plugged into the USB A port...so I in effect have a keyboard/mouse
Logged

Wheaten

  • Guest

you have a MAC, Unix based. So it will logon to the console session (first user). this session was the booting one and started MC.
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10

I have updated to the latest raspberry pi OS.
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10

The VNC viewer I was trying to use on my Win 7 desktop is VNC connect, made by RealVNC.   I chose it because RealVNC provides the server software included with official Raspberry Pi OS.
No luck yet. 
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313

I use the same...VNC Connect.....
Logged

Wheaten

  • Guest

The VNC viewer I was trying to use on my Win 7 desktop is VNC connect, made by RealVNC.   I chose it because RealVNC provides the server software included with official Raspberry Pi OS.
No luck yet.

Don't know what is going wrong. I can't reproduce it. Using the VNC server from the raspbian image works without any issues. Using it headless.
Maybe some other users have an idea
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10

OK, I finally noodled this out.   I have two inputs to my desktop monitor, so when I set up the pi, I can go back and forth between the console session with hardwire to monitor, keyboard and mouse, and the remote session from my Windows desktop.  I could see that when connecting via VNC, the remote session was not identical to the console session I see when on the hardwire connection.  So, what I think was happening was that when I first booted the pi, the pi would boot to desktop and auto log on pi as the user.  When I then connected via SSH and ran vncserver, a second session would start, that was not the console session, and that was the conflict.  I briefly attempted to have the pi boot to cli instead of desktop, but when that didn't immediately work, I set it back to boot to desktop.  Instead of connecting via SSH and running vncserver for another session, I instead went directly to my VNC viewer and connected without the :1 at the end of the network address.  Voila! it worked.   I connected to the console session, now have JRiver auto launch at boot, and I can see and control JRiver.
 
Logged

Wheaten

  • Guest

Good to hear.
Guess the ":1" you found on internet, as this is not a default setting by VNC viewer?
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10

When you connect to the pi remotely via SSH, and then run vncserver from the command line, the vnc server returns the address to use to connect to the session.  The :1 was included in the address I was was getting from the server.  Not sure exactly where I got it from, since I read through a number of threads to try to solve the problem.
Logged

Wheaten

  • Guest

if you need to re-install sometime, just activate VNC server via raspi-config. There is no need to start it from a SSH session. Guess that's why the VNC server opts for the :1, as user pi is already connected through SSH. the ":1" indicates a screen number.
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313
External drive read write permission
« Reply #61 on: April 27, 2021, 05:35:48 am »

I have the Raspi booting from an SSD just fine but I just changed the external USB drive with the music files from a hard drive to an SSD drive and copied the music files from my Mac to the SSD.

Previously the external hard drive worked OK with Raspi.   Now, the SSD is read only and as a newcomer to Linux, changing read/write permissions on the drive seems more complicated than I think it should be.

Is there an easy fix for this?
Logged

Wheaten

  • Guest

You should never have copied the files with a MAC, without taking care of owner and rights.
As I have no clue, how you did the copy or even which file system you used, it's an educated guess for me.

I should start with, having the user pi take ownership:
Code: [Select]
sudo chown pi:pi -R <path to mount>
Next some trial and error, validate by each step if you have R/W access.
Code: [Select]
sudo chmod -R 744 <path to mount>When fail:
Code: [Select]
sudo chmod -R 774 <path to mount>When fail:
Code: [Select]
sudo chmod -R 777 <path to mount>
I'll hope this will work, but I would advise to partition the disk on the Pi box and perform the copy on this box.
As it might be that the UNIX and LINUX rights will give you all kind of conflicts.
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313

Thanks

Since I just started this, I can start over.   

I have a 500GB and two 1TB SSD drive....currently using for Linux (500GB) and MC 27 (1TB) music

So I believe you are suggesting taking the blank 1TB and formatting it with Linux and then copying the files from the Mac formatted drive?

I do Tag editing on the Mac and would like to - from time to time - sync the Raspi disk with the Mac disk - so the Mac will need to read/write to the Raspi drive.

Or I suppose I could keep the above blank drive as a Mac drive and then sync it with the Raspi using SD Copy ??


Logged

Wheaten

  • Guest

Your music is on the USB thingy?
So connect that thing to the rPi, take the empty 1TB drive. As you indicate you want to connect the 1TB to both MAC and rPi, then only FAT32 is compatible. Not exFAT as this will not allow dynamic links. (you can also go for NTFS, but then you need to load additional drivers on your MAC.)
Only issue for FAT32 is the max file size of 4GB, but with music you won't reach this boundary.

You can also share the rPi 1TB disk, with your MAC via a network share.
If you TAG via JRiver, you can set the rPi as main library and have the MAC use this library. Then you can TAG on the MAC, the files from the rPi.

To sync on the MAC, you have Rsync or use filezilla
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313

OK...got it to work.  Thanks for your help

I first tried FAT32 but kept getting file size errors as you suspected.   I then tried Windows NTFS and it worked.  There were no read/write errors and I had access with both the RASPI and MAC.

Now I am going to try your suggestions for TAG edit syncing.   I'm a little fuzzy on that.
Logged

GrahamG

  • Recent member
  • *
  • Posts: 19

Hi people
Been giving this a try and all went well, until I moved the RPi to another room and rebooted with no monitor.
Now I can't connect with VNC. It looks like the x11vnc command in the boot script may be failing as I connected with putty and tried it manually.
XOpenDisplay failed (:0)
I've googled a bit, tried a few things, but no luck. Help appreciated.

Edit: OK managed to sort, I went into raspi-config and forced the display resolution to 1920x1020. Rebooted and now VNC connects.
Logged

Dennis in FL

  • Galactic Citizen
  • ****
  • Posts: 313

Interesting.   Thanks for the tip.

I wonder why forcing the moinitor resolution worked?

Logged

Wheaten

  • Guest

I've chosen a different VNC server in this tutorial. If you are going deviate from it, you should know that x11 doesn't know what resolution it need to display. So you need to let the pi know.
Logged
Pages: 1 [2]   Go Up