INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Is anyone else having trouble installing on a raspberry pi 4? [Solved]  (Read 1670 times)

Nickandnora

  • Recent member
  • *
  • Posts: 10

I have a MC 26 master license that Iíd like to use for installing JRiver on a raspberry pi 4 with 2G RAM (not the latest 4B model, but its immediate predecessor).  Iíve tried to follow the various guides available on the MC26 and MC27 pages, but so far no success.  I have been able to install the package, but when I try to launch the program from the desktop, it doesnít launch.
Iím wondering if itís a compatibility issue with Raspberry Pi OS, since I had it working previously under Buster.  One day I was fooling around with the memory settings on the pi, and it locked and wouldnít boot.  Wonít do that again.  Had to reformat the SD card and start all over.  But after I updated the OS to prepare for the re-installation, I havenít been able to get JRiver to work.  Is it a 32-bit vs 64-bit issue? I donít know, but I canít figure how to re-install. 
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 70478
  • where the buffalo roam
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #1 on: April 10, 2021, 01:09:13 pm »

Here are the instructions for MC26 and the RPi:
https://yabb.jriver.com/interact/index.php/topic,123770.0.html

It's not a 32 vs 64 bit issue.
Logged

Wheaten

  • Guest
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #2 on: April 10, 2021, 03:16:21 pm »

You can also follow the instructions on:
https://yabb.jriver.com/interact/index.php/topic,128121.0.html

Only thing different is the code installing MC27, for MC26 use this:
Code: [Select]
wget -q "http://dist.jriver.com/mediacenter@jriver.com.gpg.key" -O- | sudo apt-key add
sudo wget http://dist.jriver.com/latest/mediacenter/mediacenter26.list -O /etc/apt/sources.list.d/mediacenter26.list
sudo apt-get update
sudo apt-get install mediacenter26
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #3 on: April 10, 2021, 11:04:22 pm »

Thank you both for your replies.   I had tried following each one of those two to the letter, but neither worked.   Then I tried loading MC27, but no luck.   Maybe Iíve got a corrupt SD card, or one of the files got corrupted, and I need to start all over.   Thatís why I posted.  If Iím the only one having a problem, the trouble must be with something Iím not getting quite right.
Logged

erviv

  • World Citizen
  • ***
  • Posts: 213
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #4 on: April 11, 2021, 06:12:23 am »

I also have had no issues with loading MC27 on a rpi4. You are correct that your SD card could be the problem.
Logged
MacBook Pro i5 2.3Ghz 8 GB (early 2011) 1Tb SSD; 3 Raspberry piís 4 and 2@ 3B (o/s: Buster).

bmunroe

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 89
  • Where ever you go, there you are
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #5 on: April 11, 2021, 07:20:05 am »

I have issues with getting my NAS to mount on boot, but otherwise was able to install media center 27 just fine on my pi 4. 
Logged

Wheaten

  • Guest
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #6 on: April 11, 2021, 07:22:29 am »

Besides the SD card, you might have some issues with a voltage drop when starting MC.
I have experienced some bad performance with JRiver (and other apps) when the voltage drops below 4.9 VDC (rPi 4).
I can even  reproduce it, by connecting a USB powered DAC to the USB port.
The pi will boot, load the desktop and shows the notification on the low voltage ratings. When this notification is on, the Pi seems to be in a survival mode. MC won't start, Wifi and BT menu fails to load.

So replace the SD, and make sure the voltage to the Pi is ok.
Logged

Wheaten

  • Guest
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #7 on: April 11, 2021, 07:23:48 am »

I have issues with getting my NAS to mount on boot, but otherwise was able to install media center 27 just fine on my pi 4.

Please see my instructions in:
https://yabb.jriver.com/interact/index.php/topic,128121.0.html
Logged

Nickandnora

  • Recent member
  • *
  • Posts: 10
Re: Is anyone else having trouble installing on a raspberry pi 4?
« Reply #8 on: April 11, 2021, 06:17:19 pm »

A quick update: I reformatted the SD card, reloaded everything from scratch, and itís fixed!  All is working correctly.
Thank you everybody. 
Logged

Wheaten

  • Guest

thanks for your feedback!!
Logged
Pages: [1]   Go Up