INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Library Corruption?  (Read 430 times)

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1323
Library Corruption?
« on: January 24, 2024, 08:31:04 pm »

Since upgrading from MC31 to MC32, I've had something really odd going on...

A few days ago while watching a tv show on my main Tv (MC Server), I open MC client on my laptop and add some new tv show record rules, when suddenly I start seeing pop-up error messages on the main TV screen saying "Error creating directory E:\My Music\\2013......".  So I remote desktop into the server PC and click "OK", then again another pop up, over and over and over, with no end in sight! I cannot close MC, or drop to standard view, or even stop the tv show currently playing in the background. So I have to CTRL-ALT-DEL to KILL MC.

At the time I thought it was just some random fluke, so I restart the Server PC and everything seemed fine... But then today the same darn thing happened, again while I had MC client open on my laptop adding new tv show record rules!

So I start looking at my E drive and there are in fact several empty directories that were recently created?? Further digging, I look at a smart list for "broken links" and there are some 8 THOUSAND music file entries with those odd double back-slash directories with no Artist and/or Album Artist tags! Then I go into my library and sure enough there's like 20 random artists that suddenly have DOUBLE tracks for many but not all of their albums, that are missing those tags, and have the weird double back-slash file locations.

Maybe something went wrong during the upgrade process? Or something is triggering the Server to move or rename my music files while I'm adding new tv show record rules via my laptop mc client! Or the Server is trying to fix the dead links, but where did these dead links come from.... I ended up just doing a DELETE of everything in the "broken links" smart list and everything looks ok now. Guess I will turn on logging and try to catch it in the act. Hopefully logs will still show something even when killing MC with ctrl-alt-del.

Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫeD A3-300[RSS315HE-22] •SPA300DѫYSTSW215[15-PRX8S4]

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1323
Re: Library Corruption SCARE
« Reply #1 on: January 25, 2024, 08:59:37 am »

Found another mystery...

I have a smart list for removed items "[=ismissing([filename])]=0" which I normally use for finding tv recordings that get deleted but are still on the disk . This smart list is showing 8 music files, but they are all still in the library and on the disk!

Also, I cannot figure out how to clear them from this smart list? At the bottom, it says "0 Files" and if I right click on any of them > choose delete = nothing happens!
Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫeD A3-300[RSS315HE-22] •SPA300DѫYSTSW215[15-PRX8S4]

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1323
Re: Library Corruption?
« Reply #2 on: January 28, 2024, 04:24:36 pm »

Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫeD A3-300[RSS315HE-22] •SPA300DѫYSTSW215[15-PRX8S4]

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71493
  • Where did I put my teeth?
Re: Library Corruption?
« Reply #3 on: January 29, 2024, 12:42:59 am »

Look at the directories you've set under File Locations.  This shouldn't have the double back slash:

E:\My Music\\2013....
Logged

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1323
Re: Library Corruption?
« Reply #4 on: January 29, 2024, 09:11:46 am »

Nothing wrong there.
Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫeD A3-300[RSS315HE-22] •SPA300DѫYSTSW215[15-PRX8S4]
Pages: [1]   Go Up