INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?  (Read 358 times)

whoareyou

  • Galactic Citizen
  • ****
  • Posts: 386

A while back, the following thread discussed a 5.1 w/ 2 extra channel configuration, and that JRSS did not properly down mix
the audio.
https://yabb.jriver.com/interact/index.php/topic,134347.msg930486.html#msg930486

The last post in this thread says this was fixed, but it seems this is still an issue because this configuration still displays "Convert From 7.1 Channels To 7.1 Channels" instead of "Convert from 7.1 to 5.1"

It sure seems like JRSS should be downmixing this, and there should be 2 extra channels somewhere.

BTW - If you turn on the newish option to use the new channel mapping system, then nothing is displayed regarding what is going on.
 
So is this all working as expected or is this still an issue?




Logged
Windows 11 Pro
Intel i7-12700K / 32MBRam /
ASUS Dual GeForce RTX 4070
4K Sony x900h

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3981
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #1 on: April 02, 2024, 03:07:17 am »

appears to be mixing as expected to me, can you post a sample to show exactly what you think is wrong?
Logged

whoareyou

  • Galactic Citizen
  • ****
  • Posts: 386
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #2 on: April 02, 2024, 08:37:53 am »

Images showing Audio Path with and without 2 extra channels.  Only difference between the two is the 2 extra channels.
Playing back a 7.1 bluray backup by MKV.

Also, when selecting the "new extra channels system" Audio Path does not show a conversion at all when 2 extra channels are added.

Is this how you think it should work?
Logged
Windows 11 Pro
Intel i7-12700K / 32MBRam /
ASUS Dual GeForce RTX 4070
4K Sony x900h

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3981
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #3 on: April 02, 2024, 10:23:58 am »

I didn't look at audio path, I just measured the actual output (which seems correct). The audio path info certainly looks wrong so that seems like a bug.
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42047
  • Shoes gone again!
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #4 on: April 02, 2024, 11:21:38 am »

I'll try to make this better using the new system tomorrow.  Testing appreciated once it's out.  Thanks.
Logged
Matt Ashland, JRiver Media Center

whoareyou

  • Galactic Citizen
  • ****
  • Posts: 386
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #5 on: April 02, 2024, 11:49:53 am »


I'll try to make this better using the new system tomorrow.  Testing appreciated once it's out.  Thanks.

Still a bit confused with the old system.

Is the old system's 7.1 -> 7.1 notation correct, but it's really being downmixed?  I can check it out later, but not at my machine at moment, so if anyone knows the answer, I'd appreciate.

Thanks.
Logged
Windows 11 Pro
Intel i7-12700K / 32MBRam /
ASUS Dual GeForce RTX 4070
4K Sony x900h

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3981
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #6 on: April 02, 2024, 11:59:19 am »

I already said it's mixing as expected as far as I can see
Logged

whoareyou

  • Galactic Citizen
  • ****
  • Posts: 386
Re: JRSS Mixing - 7.1 > 5.1 W "Extra Channels" Not Working Properly?
« Reply #7 on: April 02, 2024, 12:17:00 pm »

Sorry, missed that somehow.  Thanks.
Logged
Windows 11 Pro
Intel i7-12700K / 32MBRam /
ASUS Dual GeForce RTX 4070
4K Sony x900h
Pages: [1]   Go Up