INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: MC crashing upon clicking "Audio" on left pane  (Read 1450 times)

squem

  • Recent member
  • *
  • Posts: 11
MC crashing upon clicking "Audio" on left pane
« on: June 01, 2013, 05:00:21 pm »

Hi,

I have a clean install of MC now, and when I click on "Audio" (below "Playing Now"), the app crashes.  It only happens once media has been added.  If the library is cleared, it's okay again.  Happens after adding either a single mp3 or a single ALAC.  Rebooting in safe mode doesn't help.

Very keen to try MC out!

I'm running OS 10.6.8 on a 2 Ghz Intel Core Duo.


Thanks for your time!
Logged

squem

  • Recent member
  • *
  • Posts: 11
Re: MC crashing upon clicking "Audio" on left pane
« Reply #1 on: June 01, 2013, 05:02:00 pm »

I should add that I've tried setting audio output to both Core Audio & Null.

I'll try with an external DAC, if you think it might help.


Thanks again
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71759
  • Where did I put my teeth?
Re: MC crashing upon clicking "Audio" on left pane
« Reply #2 on: June 01, 2013, 05:15:24 pm »

I'm sorry, but I have no idea why it's happening.  10.6.8 is about as old an OS as MC will run on.

It's possible there is a firewall or other software preventing MC from getting cover art.  You could go into options to turn off access.

MC has logging under Help.  By reading the previous log after a crash, you might see something at the bottom.
Logged

squem

  • Recent member
  • *
  • Posts: 11
Re: MC crashing upon clicking "Audio" on left pane
« Reply #3 on: June 01, 2013, 05:59:59 pm »

Sigh, that must be it.  This machine is just creaky enough to hit the aluminum ceiling:  i'm trapped at 10.6.8 (Core Duo, not Core 2 Duo).

Well thank you once more for your attention.  I'm wowed, to say the least, with your responsiveness and look forward to giving this another go, once I drag myself out of 2006.

Be well



PS here are the crashy bits from the log:

Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Crashed Thread:  9

...

Thread 9 Crashed:
0   libJRImage.dylib                 0x1b02b30e 0x1b000000 + 176910
1   libJRImage.dylib                 0x1b02b831 0x1b000000 + 178225
2   com.jriver.MediaCenter18         0x002b6dad start + 2834765
3   com.jriver.MediaCenter18         0x002b6b1d start + 2834109
4   com.jriver.MediaCenter18         0x002ba56a start + 2849034
5   com.jriver.MediaCenter18         0x002bc1f3 start + 2856339
6   com.jriver.MediaCenter18         0x0044414c start + 4461804
7   libSystem.B.dylib                0x01776259 _pthread_start + 345
8   libSystem.B.dylib                0x017760de thread_start + 34

Thread 9 crashed with X86 Thread State (32-bit):
  eax: 0x0000000b  ebx: 0x00000003  ecx: 0x00000000  edx: 0x00000005
  edi: 0x00000003  esi: 0x1b02b20b  ebp: 0xb043fa28  esp: 0xb043f910
   ss: 0x0000001f  efl: 0x00210206  eip: 0x1b02b30e   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x0000001f   gs: 0x00000037
  cr2: 0xffe2a3cc
Logged
Pages: [1]   Go Up