INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Can't load library from MC19 server  (Read 1924 times)

gigglez4dm

  • Regular Member
  • Member
  • *
  • Posts: 2
  • Change this by choosing profile
Can't load library from MC19 server
« on: December 07, 2013, 05:42:58 pm »

Hi!

First, THANK YOU for releasing a Linux version! We've been using MC for several years now and love it, and it's awesome that I can now install it on my Linux Mint desktop. However, I can't connect to the library server that runs on our main media server, which is a Win7 box on the same subnet. I've made sure that the main server is on MC19 and running the latest build available (19.0.67), and I have a variety of other clients connecting to it (phones and tablets and laptops) so I know that the server is working fine in general. On Linux Mint I have the latest build installed (19.0.89) using the deb package. The install was fine and it seems to work more or less just fine in stand-alone mode. I copied some mp3 files locally and it imported them just fine and plays them. But when I try to add the library from the server, it fails. First, if I put in the Access key, as soon as I hit "OK" the whole program crashes. If I instead put in the IP address and port it's able to connect, but it tells me that "The Server is a different version or not a Library Server." It says that the Server database version is 21, and the Client database version is 24.

I've looked through all the options I can find and in every menu and submenu on the server, but for the life of me I can't find any options to update the database. I've already checked for updates and installed them. I've tried creating a new library on the server but I get the same results. What else can I do?

Thanks!
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71460
  • Where did I put my teeth?
Re: Can't load library from MC19 server
« Reply #1 on: December 07, 2013, 05:52:00 pm »

The latest Windows version, 19.0.87, is on the MC19 board.  It's worth a try.
Logged

gigglez4dm

  • Regular Member
  • Member
  • *
  • Posts: 2
  • Change this by choosing profile
Re: Can't load library from MC19 server
« Reply #2 on: December 07, 2013, 05:57:09 pm »

Ugh, sorry, this was totally self-inflicted. Even though I had updated the server to MC19, and I had closed and re-opened MC multiple times, the old MC17 media server service was still running. I stopped that and had MC19 start *its* media server service, and now I can connect just fine. Sorry!
Logged
Pages: [1]   Go Up