INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Import a single folder not working  (Read 1399 times)

crawfofd

  • World Citizen
  • ***
  • Posts: 129
Import a single folder not working
« on: October 14, 2014, 06:17:22 pm »

okay, so i deleted all my shows and movies and wanted to reload them.  Oh but guess what it wont let me.  I guess you have to do something special to reload a import if it has already be imported once.  Maybe that was the wrong thing to do, but there is no place to tell you that it is wrong. So could someone please let me in on the secret, cause looking for a answer on this forum is like looking for a needle in a hay stack.  Yes it might seem like I'm a little upset. Heck ya.  Every time I try to find something on this forum/support site, it is a major job.

Please, please create some documentation that you can look at without having to search for days. 

And please can someone tell me why you cant just delete your files and reload them.

Logged

kensn

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1361
Re: Import a single folder not working
« Reply #1 on: October 14, 2014, 07:10:09 pm »

You might try Options - Library & Folders - Configure auto-import and add the folder to the folders to watch and uncheck Ignore files previously removed from library.

Ken
Logged
If(IsEmpty([Coffee Cup]), Coffee, Drink)

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: Import a single folder not working
« Reply #2 on: October 14, 2014, 07:17:35 pm »

The import system in MC actually does have some pretty good documentation.  I know, because I wrote it:

http://wiki.jriver.com/index.php/Import
http://wiki.jriver.com/index.php/Auto-Import
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

crawfofd

  • World Citizen
  • ***
  • Posts: 129
Re: Import a single folder not working
« Reply #3 on: October 14, 2014, 07:53:17 pm »

Thanks kensn and glynor for your responses.

glynor I will definately look over your documentation. 
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: Import a single folder not working
« Reply #4 on: October 14, 2014, 08:01:16 pm »

I will admit, that particular detail isn't in there (it is now on my list to add further details about the options and a Troubleshooting section, but my list is long and my time is short).  It is covered in brief elsewhere on the Wiki, but it is buried in other sections that are (much more) out of date.

However, kensn's tip is the answer, almost certainly.

MC ignores files you manually remove by default.  That's because otherwise it would drive people nuts because you'd remove the files (but not delete them from disk) and then Auto-Import would instantly re-import them.  To get it to import everything in the specified directories, you can de-select that option.  Also the drag-and-drop and Shell Extensions methods of Importing don't respect this rule and always import the files provided.

However...

I should note, if your original goal (before you discovered this problem) was to remove the files in order to re-import them "fresh" then you'll be sad even when you get them re-imported, as they'll re-import just like they were before (or, pretty much).  That's because of two factors:

1. MC tracks files you've deleted in the special, hidden, Removed database.  This is how it does the Ignore Previously Removed Files trick, and it also allows for an (often convenient) undo.  If you accidentally remove files (upon which you spent considerable time making the tags "just so") from your Library?  Just re-import them.  When MC does, it essentially "undeletes" them, so nothing gets lost.

2. MC automatically syncs a ton of metadata to the in-file tags, so it is essentially creating a little mini "database backup" within each file.  This can be disabled if desired.

If you do need to remove files and import them fresh, there is a way.  You need to remove them from this Removed database after you remove them from MC "proper".  To do this, you need to make a special Media View or Smartlist that shows them:
http://yabb.jriver.com/interact/index.php?topic=72593.msg491631#msg491631
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

crawfofd

  • World Citizen
  • ***
  • Posts: 129
Re: Import a single folder not working
« Reply #5 on: October 14, 2014, 09:18:27 pm »

Thanks for the explanation glynor.  It seems very complicated. I will look it all over in the morning when my mind is fresh.  Hopefully I will figure it out. It gets pretty irritating when you look through hours of posts and not find what your looking for. I guess got spoiled with SageTV.

Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: Import a single folder not working
« Reply #6 on: October 15, 2014, 01:12:13 am »

Hmmm...

Actually, I was wrong.  I just tested it, and the Ignore files previously removed from Library option in the Auto-Import configuration dialog only applies to running Auto-Import on watched folders.  It does apply to doing Tools > Import > Run Auto-Import Now, but it does not apply to doing Tools > Import > Import a single folder.  That's good.  Otherwise I was going to complain it shouldn't be in the Auto-Import dialog alone.

So, it really isn't that complicated (and even less so than I thought).  Perhaps I assumed too much about what you were trying to do.

If you just want to re-import them, either use any of the methods to Import other than Auto-Import.  Or disable that option (which does the exact opposite of what you want), and run another scan.

If you were trying to do more, explain what you were trying to do, and we can help you.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/
Pages: [1]   Go Up