INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Zone Startup Volume is not respected  (Read 2004 times)

jeffspl311

  • Regular Member
  • World Citizen
  • ***
  • Posts: 206
  • Reaper of Righteous Riffs
Zone Startup Volume is not respected
« on: December 05, 2014, 12:16:07 pm »

I've set the speaker zone to 80, and the headphone zone to 30, and saved, and quit. When I restart MC, both zones remain at 80 (which was my old default from MC 19).

Oddity #1: This only happens on my laptop. It works as expected on my desktop. On both systems the audio device is "Default Audio [Direct Sound]"

Oddity #2: Before I changed the startup volumes, the default value was "-1"... what's that about?

Cheers,
Jeff
Logged

luckyaua

  • Junior Woodchuck
  • **
  • Posts: 72
Re: Zone Startup Volume is not respected
« Reply #1 on: December 12, 2014, 03:12:46 pm »

Same problem 4me!
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5187
  • "Linux Merit Badge" Recipient
Re: Zone Startup Volume is not respected
« Reply #2 on: December 12, 2014, 04:30:11 pm »

Is your laptop set to "system volume" instead of "internal volume"?  If so, try changing it.
Logged

luckyaua

  • Junior Woodchuck
  • **
  • Posts: 72
Re: Zone Startup Volume is not respected
« Reply #3 on: December 12, 2014, 04:31:58 pm »

my setting is "internal volume"
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5187
  • "Linux Merit Badge" Recipient
Re: Zone Startup Volume is not respected
« Reply #4 on: December 12, 2014, 07:23:19 pm »

That's very odd then.  The startup volume setting works perfectly for me.  Do you have the other zone-independent startup volume setting (under options--> startup) set to something different?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42079
  • Shoes gone again!
Re: Zone Startup Volume is not respected
« Reply #5 on: December 12, 2014, 08:31:58 pm »

I just set two zones (both using internal volume) to two different levels.  I restarted and they loaded perfectly.  So I can't make it fail.

Any tips to reproduce?
Logged
Matt Ashland, JRiver Media Center

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71812
  • Where did I put my teeth?
Re: Zone Startup Volume is not respected
« Reply #6 on: December 12, 2014, 08:53:16 pm »

What if one is WDM and one isn't?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42079
  • Shoes gone again!
Re: Zone Startup Volume is not respected
« Reply #7 on: December 15, 2014, 08:16:35 am »

Bump.  Still looking for a way to make it fail.

Thanks.
Logged
Matt Ashland, JRiver Media Center

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5187
  • "Linux Merit Badge" Recipient
Re: Zone Startup Volume is not respected
« Reply #8 on: December 15, 2014, 08:22:43 am »

One hunch I had: there's a second startup volume setting under options-->startup-->, which appears to be not zone specific.

How does MC resolve conflicts between what's in options-->startup and the zone specific settings in options-->audio?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42079
  • Shoes gone again!
Re: Zone Startup Volume is not respected
« Reply #9 on: December 15, 2014, 08:46:52 am »

Next build:
Changed: Removed Options > Startup > Set volume because each zone has its own startup volume.

It was a redundant option and I'm not sure how the crossing would interact.  Maybe this is the explanation?  I hope so.
Logged
Matt Ashland, JRiver Media Center

luckyaua

  • Junior Woodchuck
  • **
  • Posts: 72
Re: Zone Startup Volume is not respected
« Reply #10 on: December 15, 2014, 10:42:06 am »

I hope so too!!
Logged

dean70

  • Citizen of the Universe
  • *****
  • Posts: 508
Re: Zone Startup Volume is not respected
« Reply #11 on: December 15, 2014, 02:16:05 pm »

One use case is if you have multiple zones, the ununsed zone volume will revert to 20% after a period of time. When you switch to that zone, it starts playing at the volume protection level of 20%.

Maybe the vol protection value should only apply to zones that have been used since startup (or the vol protection should revert to the startup value rather than a fixed 20%)?

Logged
Pages: [1]   Go Up