INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: [solved] Theater View Customisation : command line arguments  (Read 1154 times)

beginner44

  • Junior Woodchuck
  • **
  • Posts: 72
[solved] Theater View Customisation : command line arguments
« on: December 21, 2014, 07:35:22 am »

Hello,

I'm using MC20.0.44.

Before I've been using MC19, and MC18 even before.

I've customized the Theater View in order to launch a homemade .exe (built with AutoIt) on Exit, instead of the usual Exit commands.

I'm not sure if it is related to the 20 version or a specific buid within that version, but now when the .exe is launched, I can see a MS Dos window showing the launch of the .exe (see attached picture).

I would like to know what are the arguments one should input in the configuration window (see 2nd attached pic) in order to have a "silent" execution.

Many thanks in advance.

BG44
Logged

Trond-Eirik

  • Junior Woodchuck
  • **
  • Posts: 78

The arguments are passed to your app from the command line, so I do not think that you can set a argument there to get a silent execution, as the command window you see is a window that MC20 is using to start your program - ergo, any arguments you set will never affect how that window is shown.

How that window is shown is controlled by MC, meaning that this probably is a change (bug?) in how MC20 starts external programs compared to previous versions.
Logged

beginner44

  • Junior Woodchuck
  • **
  • Posts: 72

@Trond-Eirik :

thank you for your answer. I agree with your analysis.


Quote
How that window is shown is controlled by MC, meaning that this probably is a change (bug?) in how MC20 starts external programs compared to previous versions.

i'm afraid so.

Let's hope that the good people at MC will have a look to it. Should not be a big deal for them  8)

Take care,

BG44
Logged

tls62dk

  • Galactic Citizen
  • ****
  • Posts: 406

Try and update to the latest build. I think your problem was fixed in version 20.0.45.
Logged

beginner44

  • Junior Woodchuck
  • **
  • Posts: 72

@tls62dk : thanks for the info !

The problem looks solved indeed  8)
Logged
Pages: [1]   Go Up