INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Video playback doesn't work and no sound  (Read 1997 times)

rinring

  • Recent member
  • *
  • Posts: 47
Video playback doesn't work and no sound
« on: December 23, 2014, 04:25:26 am »

I've experienced in my two KUbuntu 14.04 and 14.10 computers this problem:

- No video playback with all programs like Dragon Player, VLC, or playback with no sound.
- In Google Chrome and Firefox, no playback of videos or only playing 10 seconds with no sound, including sites like youtube.com, by using Flash player or HTML5 video support.

The cause:
- It was set up by default this Audio Device in Media Center 20 for linux: front:CARD=PCH,DBV=0 [ALSA]

Solution:
- Use this other device: default:CARD=PCH [ALSA]

This solved me the problem in one computer. 
In the other one solves the problem with third party software, but Media Center is unable to play any music.
I have to experiment a little more...

Luckily, I've discovered the cause of the problem with 3rd party soft.  I was worried.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Video playback doesn't work and no sound
« Reply #1 on: December 23, 2014, 04:25:50 pm »

I've experienced in my two KUbuntu 14.04 and 14.10 computers this problem:

- No video playback with all programs like Dragon Player, VLC, or playback with no sound.
- In Google Chrome and Firefox, no playback of videos or only playing 10 seconds with no sound, including sites like youtube.com, by using Flash player or HTML5 video support.

The cause:
- It was set up by default this Audio Device in Media Center 20 for linux: front:CARD=PCH,DBV=0 [ALSA]

Solution:
- Use this other device: default:CARD=PCH [ALSA]

This solved me the problem in one computer. 
In the other one solves the problem with third party software, but Media Center is unable to play any music.
I have to experiment a little more...

Luckily, I've discovered the cause of the problem with 3rd party soft.  I was worried.

This is because when you use the hardware device ( front:CARD=PCH,DBV=0 [ALSA]), only one program can use it at a time.
If MC is not PLAYING or in a gapless play state (hit the stop button again to make sure), then the other programs should be able to open the audio device fine. Video playback (ie VLC) will be stopped if the audio device can't be opened!
When you use the default device (default:CARD=PCH [ALSA]) you are talking to a multiplexed mixer. Multiple programs can play to this simultaneously IF they all have the same sample rate.
This means you are usually stuck at 48k and you need to adjust DSP studio accordingly to resample all not 48k rates to 48k.
Logged

rinring

  • Recent member
  • *
  • Posts: 47
Re: Video playback doesn't work and no sound
« Reply #2 on: December 24, 2014, 07:51:14 am »

Thanks for your answer.
I've tried the default:CARD=PCH [ALSA]
It complains about sampling rate when I try to play something.
Then I activate the Output format to 48 KHz in the DSP settings.
The problem is that I have an infinite buffering.

Other problem, is that the 2nd time I open the DSP settings, the dialog appears completely blank.  I have to restart Media Center.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7402
  • The color of Spring...
Re: Video playback doesn't work and no sound
« Reply #3 on: December 24, 2014, 08:14:01 am »

Other problem, is that the 2nd time I open the DSP settings, the dialog appears completely blank.  I have to restart Media Center.

Resize the window.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones
Pages: [1]   Go Up