INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Year field anomaly causes TRACKINFO_INSERT_YEAR to show entire Date  (Read 864 times)

MusicHawk

  • Citizen of the Universe
  • *****
  • Posts: 796

A new oddity in recent builds, a two-headed oddity:

I use a visualization that uses TRACKINFO_INSERT_YEAR to show the value of the Year field. This has worked correctly for years, showing just the 4-digit year I type in the Year field, such as 2015 or 1995 or whatever.

It still works correctly for existing songs. But tracks I've added in recent months show the full date.  I type 1995 in Year field. It then shows 1995.

But upon playback, TRACKINFO_INSERT_YEAR shows the year and month and date, such as 1995-01-21 -- the year that I typed in Year, but also the month and date of whatever date I typed in the Year field.

In Tags, field Year looks correct, 1995, but TRACKINFO_INSERT_YEAR shows what seems to be the Date field, not the Year field.

If right now I retype the Year field, such type in 2005, that's what I see in Year. But the visualization shows 2005-01-21. Why?

Seems like two things are interacting:

1. TRACKINFO_INSERT_YEAR is passive, it simply shows what is in the Year field. So if the Year field has more than just just the 4 digit year, that's what gets displayed.

2. But I don't see more than the year in the Year field! I type in 2005, that's what I see in Year, but the visualization shows 2005-01-21.

This used to work perfectly, I have tens of thousands of tracks with 4-digit Year typed into MC over the years. But it is a problem for tracks I've added in recent months, so I now have hundreds of tracks that show Year field 4-digit YYYY but TRACKINFO_INSERT_YEAR displays the Year field data as YYYY-MM-DD.

I don't even know a track has this problem unless I play it and therefore see the output of TRACKINFO_INSERT_YEAR. The Year field tag always looks normal.

When I notice the problem in a visualization during playback, I can try to fix the track, by retyping the Year field, sometimes again and again until it sticks -- which I can't verify until I play the track and view the Year via TRACKINFO_INSERT_YEAR. Doing this to find and fix hundreds and hundreds and hundreds of tracks is not a fun job. My library seems to now be damaged by this.

My guess: something "smart" in the Year field is not-so-smart. Any chance MC can be fixed to not do this in the future, AND fix bad data in existing Year fields?








Logged
Managing my media with JRiver since Media Jukebox 8 (maybe earlier), currently use Media Center for Audio/Music and Photos/Videos.
My career in media spans Radio, TV, Print, Photography, Music, Film, Online, Live, Advertising, as producer, director, writer, performer, editor, engineer, executive, owner. An exhausting but amazing ride.

MusicHawk

  • Citizen of the Universe
  • *****
  • Posts: 796
Re: Year field anomaly causes TRACKINFO_INSERT_YEAR to show entire Date
« Reply #1 on: February 17, 2015, 02:27:51 pm »

This problems is very real, and is actually two problems. One problem might be a mystery, but the second seems like a bug that, if fixed, would make the first problem easier to ignore.

PROBLEM #1 Sometimes the YEAR field gets a full date in it. This should not happen, and I haven't found when/why this happens. The 4 digit year was typed in the YEAR field, but MC then added the current day and month and stored the full date. The problem isn't obvious because the full date is not visible in a view's YEAR column, but is definitely there. This has happened to many but not all of my tracks, some tagged years ago, but it did not become visible until MC19 and MC20. The only fix, once I find this, is to re-enter the YEAR field value, sometimes it takes 2 or 3 tries to get it to stick. But the first challenge is finding which YEAR fields have this problem.

BUG #2: Visualization web field TRACKINFO_INSERT_YEAR does not actually display just the YEAR, it displays whatever is in the YEAR field. So, when the problem has put a full date in the YEAR field, that's what is displayed in the visualization. If TRACKINFO_INSERT_YEAR could actually extract and show ONLY the YEAR, visualizations would not be broken due to problem #1. It seems that this behavior was changed, possibly in MC19 and now in MC20, to show the entire field's content without parsing for just the YEAR portion.

One theory: I often use MC15 for tagging music files, because it's the last MC version that allowed fast, efficient list tagging rather than the multi-click "search" behavior. But my playback, and other uses, is MC20. Could the YEAR bug arise because of different behavior across MC15 and later versions? If so, I never saw the problem until I started playing tracks with MC19 and MC20.

Editorial: I treasure having MC15 on my main music editing/tagging PC, mind-boggling how clumsy later versions are.
Logged
Managing my media with JRiver since Media Jukebox 8 (maybe earlier), currently use Media Center for Audio/Music and Photos/Videos.
My career in media spans Radio, TV, Print, Photography, Music, Film, Online, Live, Advertising, as producer, director, writer, performer, editor, engineer, executive, owner. An exhausting but amazing ride.
Pages: [1]   Go Up