INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: MC20 crashes when using convolution [Solved]  (Read 2512 times)

matze81479

  • Recent member
  • *
  • Posts: 15
MC20 crashes when using convolution [Solved]
« on: January 23, 2015, 02:24:06 pm »

Hi,

when using DSP Studio -> Convolution, MC20 Linux crashes in most cases when switching to an audio file with another resolution:

(1) Playback of 96 kHz .flac files -> OK
(2) Switch to another 96 kHz album -> OK
(3) Start playback of a 44.1 kHz .flac file -> MC20 crashes

Typical error messages on the terminal window after crashing are (sorry, it's in German):

Quote
*** Error in `mediacenter20': free(): invalid pointer: 0xeefca208 ***
Abgebrochen (Speicherabzug geschrieben)
or
Quote
*** Error in `mediacenter20': corrupted double-linked list: 0xeee3e7c0 ***
Abgebrochen (Speicherabzug geschrieben)

Without Convolution, everything works fine. Also when starting MC20 and playing only tracks of the same sample rate. And it does not matter which sample rates you choose.

My system: Notebook with
- Ubuntu 14.04.1 64bit (Partition 1) and Ubuntu Studio 14.04.1 64bit with Low-Latency Kernel (Partition 2)
- MC20 Linux Build 20.0.58

Any ideas?

Regards,
Matthias
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41976
  • Shoes gone again!
Re: MC20 crashes when using convolution
« Reply #1 on: January 23, 2015, 02:51:47 pm »

Could you provide the files you're using for convolution as well as a link to this thread to bob at jriver dot com?

Thanks.
Logged
Matt Ashland, JRiver Media Center

matze81479

  • Recent member
  • *
  • Posts: 15
Re: MC20 crashes when using convolution
« Reply #2 on: January 25, 2015, 03:22:13 am »

Thanks, Matt. Mail has been sent to Bob.

Regards
Matthias
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: MC20 crashes when using convolution
« Reply #3 on: January 26, 2015, 03:34:05 pm »

Can't reproduce this.
What are your audio settings for track change?
Are you stopping between the first album and second or just double clicking on something else?
Logged

matze81479

  • Recent member
  • *
  • Posts: 15
Re: MC20 crashes when using convolution
« Reply #4 on: January 26, 2015, 04:59:11 pm »

Hi Bob,

I've tried it with every possible setting for track change. MC20 crashes with all of them. Usually it crashes immediately after changing to an album with another resolution, sometimes after one or two further tracks.

And it crashes also after stopping, waiting, and starting the next album.

First I thought that it could be related to my Antelope DAC. But it crashes also with the Notebook's internal audio device.

And it's not only a Linux issue - it crashes also with Win7 64bit and MC19.

Regards
Matthias
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71470
  • Where did I put my teeth?
Re: MC20 crashes when using convolution
« Reply #5 on: January 26, 2015, 05:39:34 pm »

But it's fine if you don't use convolution?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41976
  • Shoes gone again!
Re: MC20 crashes when using convolution
« Reply #6 on: January 27, 2015, 11:00:26 am »

We've got a possible fix coming next build.  Hang tight, and please let us know (because we couldn't reproduce the crash, but found something a little suspicious).
Logged
Matt Ashland, JRiver Media Center

matze81479

  • Recent member
  • *
  • Posts: 15
Re: MC20 crashes when using convolution
« Reply #7 on: January 27, 2015, 02:05:51 pm »

But it's fine if you don't use convolution?
Yes, without convolution everything works fine.
Logged

matze81479

  • Recent member
  • *
  • Posts: 15
Re: MC20 crashes when using convolution
« Reply #8 on: January 27, 2015, 02:09:07 pm »

We've got a possible fix coming next build.  Hang tight, and please let us know (because we couldn't reproduce the crash, but found something a little suspicious).
Thanks. I'm looking forward to test it.
Logged

matze81479

  • Recent member
  • *
  • Posts: 15
Re: MC20 crashes when using convolution
« Reply #9 on: January 31, 2015, 02:18:23 pm »

We've got a possible fix coming next build.  Hang tight, and please let us know (because we couldn't reproduce the crash, but found something a little suspicious).
Hi Matt,

the fix works  :) Starting with Build 20.0.63 there were no more crashes. Thanks a lot !!!
Logged
Pages: [1]   Go Up