INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)  (Read 4431 times)

EdM244

  • Recent member
  • *
  • Posts: 36
Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« on: February 17, 2015, 02:51:34 pm »

Should "File Types" be missing from the Options Menu? MC won't import or play .ape files. ??
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71471
  • Where did I put my teeth?
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #1 on: February 17, 2015, 02:53:09 pm »

Import options are under Tools > Import > Auto import.  Edit the directories you want to import.
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #2 on: February 19, 2015, 12:09:57 pm »

Scrolling through the edit options, I can see that "Monkey's Audio" is already selected. However, after running auto-import only the .ape files fail to import. The message says that these files were skipped because they were previously determined to be bad. ?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #3 on: February 20, 2015, 10:41:16 am »

Particular revision of ape files?
My sample test file works.
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #4 on: February 20, 2015, 11:09:32 am »

(Monkey's Audio, Version 3.99.)  VLC will play the files (Ubuntu). MC has no problem playing the files on Windows computers.

Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #5 on: February 20, 2015, 11:36:56 am »

(Monkey's Audio, Version 3.99.)  VLC will play the files (Ubuntu). MC has no problem playing the files on Windows computers.

You can test to see if the file will play at all by starting playback from the command line.

in a terminal as the user MC normally runs under:

mediacenter20 path-to-file-to-play.ape
If the path has spaces or linux shell characters in it put double quotes around the filepath.

Can you email me a small one that doesn't play?
bob (at) jriver (dot) com
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #6 on: February 20, 2015, 12:11:14 pm »

Email sent.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #7 on: February 20, 2015, 03:08:31 pm »

Email sent.
Works fine for me. Imports and plays.

Try making a smartlist of deleted files:

Create a smart playlist, name it "deleted"
Rules:
Mediatype is Audio
Limit Database to Removed

click OK

click on the deleted smartlist
find a track that doesn't work
right-click on it and delete it
hit F5 to refresh the list.
if it shows up again repeat the right-click delete, refresh.
when it's gone try importing the folder that track was in again.
does it import?
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #8 on: February 20, 2015, 03:33:39 pm »

I'll work on that, but MC won't import the files period. I copied the file I sent you to the music folder on the Ubuntu computer. When I select File>Open Media File>Music>Open... MC sends the following warning, "There is nothing to play."

Glad it worked for you.
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #9 on: February 20, 2015, 03:43:02 pm »

Created the smartlist as you suggested. No files.
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #10 on: February 20, 2015, 04:17:20 pm »

Copied another file from the same folder directly to the music folder. MC opened it's playing. Now, back to the problem with importing.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #11 on: February 20, 2015, 04:21:04 pm »

I'll work on that, but MC won't import the files period. I copied the file I sent you to the music folder on the Ubuntu computer. When I select File>Open Media File>Music>Open... MC sends the following warning, "There is nothing to play."

Glad it worked for you.
I can't spend much time on this since you are on an unsupported distro and it works here.
The filetypes to play are determined by the input plugin and the FileAssociations.xml which allows ape by default.
You can try:
ldd -d /usr/lib/jriver/Media\ Center\ 20/Plugins/libin_APE.so
and see if anything is missing.

If your Machine Settings.ini file was corrupted you might see this result too.
You could make a backup of your library.
Then save a copy of your settings files, they are in ~/.jriver/Media Center 20/Settings, just rename that directory to Settings.bak. MC will recreate it when it runs again. Be aware that this will prompt you for the registration code.


Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #12 on: February 20, 2015, 04:25:38 pm »

Copied another file from the same folder directly to the music folder. MC opened it's playing. Now, back to the problem with importing.
Sounds like you have permissions issues.
Logged

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #13 on: February 20, 2015, 05:34:56 pm »

1. When I copied a file from the windows computer to the public (shared) folder on the Ubuntu computer and then to the music folder I noticed a "lock" icon. Wouldn't play.

2. When I copied from the same file from the shared folder on the Ubuntu computer and copied to the music folder there was no "lock" icon. It played.

Found the fix.... Tools>Import>Configure Auto-Import>Ignore files previously removed from the library (Unchecked)

If this distro isn't supported, is it advisable to purchase a license for it? Which supported distro would you reccommend? I have a license for Windows.

Thanks for your time.



Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7403
  • The color of Spring...
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #14 on: February 20, 2015, 05:39:25 pm »

Media Center officially supports Debian Wheezy however Media Center works completely fine in Ubuntu if you have everything setup correctly (Ubuntu is based on Debian). Your issue definitely sounds like a permissions issue. Did you check whether or not your music directory is mounted with read+write permissions?
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #15 on: February 20, 2015, 06:03:24 pm »

After two weeks of stumbling around and trying to learn a new language, I think I've got MC working almost as good with Ubuntu as I have with windows. Not sure what is, (Linux audio stack?) but really enjoy listening to music with this setup. Just concerned about buying a license for something that isn't supported.

As I said above, the issue seems to have been resolved by unchecking "Ignore files previously removed from the library" The files are now imported and play.

Thanks.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7403
  • The color of Spring...
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #16 on: February 20, 2015, 06:15:30 pm »

While it may be unofficially supported there are forum members like myself who do try to help others with any issues they encounter running MC on various Linux distributions. Did you check out my Ubuntu thread posted in this forum section? It's got some cool stuff you may be interested in.

The *only* potential issue with MC and Ubuntu I can see down the line is if it works with Mir (display server Canonical is working on to replace X) and whether or not XMir will help with this. The same can be said about Wayland and XWayland. We'll see within the next year or two.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

EdM244

  • Recent member
  • *
  • Posts: 36
Re: Tools>Options Menu>File Types (Ubuntu 14.04 LTS)
« Reply #17 on: February 20, 2015, 06:26:55 pm »

Where would we all be at without new challenges?

Thank you.
Logged
Pages: [1]   Go Up