INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Windows 10 wasapi instability  (Read 6610 times)

danielpugh

  • Recent member
  • *
  • Posts: 15
Windows 10 wasapi instability
« on: August 02, 2015, 08:50:12 am »

Windows 10 install, latest version of mc.   plays everything fine through directsound.   When playing via dac using wasapi all tracks randomly stop playing. When this happens media centre is unresponsive.   Have tried running as admin,  longer buffer,  playing from memory. Cpu,  ram and memory are low.

Nas,  network and pc are rock solid otherwise, and not having any issues(with windows

Any ideas?

Update: music via directsound just stopped!
Logged

ferday

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1732
Re: Windows 10 wasapi instability
« Reply #1 on: August 03, 2015, 10:53:00 am »

Sounds like driver issues...try reinstalling drivers for the DAC
Logged

danielpugh

  • Recent member
  • *
  • Posts: 15
Re: Windows 10 wasapi instability
« Reply #2 on: August 03, 2015, 10:57:35 am »

Im using toslink (realtek motherboard). They work fine for logitech media server...
Logged

Manfred

  • Citizen of the Universe
  • *****
  • Posts: 1023
Re: Windows 10 wasapi instability
« Reply #3 on: August 03, 2015, 11:42:19 am »

In Windows 10 MS has made someone Changes to the WASAPI Interface
https://msdn.microsoft.com/en-us/library/windows/hardware/mt298187(v=vs.85).aspx
My Devialet AIR is also not working . ?
Logged
WS (AMD Ryzen 7 5700G, 32 GB DDR4-3200, 2x2 TB SDD, LG 34UC98-W)-USB|ADI-2 DAC FS|Canton AM5 - File Server (i3-3.9 GHz, 16GB ECC DDR4-2400, 46 TB disk space) - Media Renderer (i3-3.8 GHz, 8GB DDR4-2133, GTX 960)-USB|Devialet D220 Pro|Audeze LCD 2|B&W 804S|LG 4K OLED )

Manfred

  • Citizen of the Universe
  • *****
  • Posts: 1023
Re: Windows 10 wasapi instability
« Reply #4 on: August 03, 2015, 12:08:11 pm »

I reinstalled my Devialet AIR 2.1.4. and it works now. What sound interface are you using?
Logged
WS (AMD Ryzen 7 5700G, 32 GB DDR4-3200, 2x2 TB SDD, LG 34UC98-W)-USB|ADI-2 DAC FS|Canton AM5 - File Server (i3-3.9 GHz, 16GB ECC DDR4-2400, 46 TB disk space) - Media Renderer (i3-3.8 GHz, 8GB DDR4-2133, GTX 960)-USB|Devialet D220 Pro|Audeze LCD 2|B&W 804S|LG 4K OLED )

danielpugh

  • Recent member
  • *
  • Posts: 15
Re: Windows 10 wasapi instability
« Reply #5 on: August 03, 2015, 12:48:32 pm »

I saw the same article and was wondering the same thing.   I have unplugged av amp (hdmi straight to tv) ,  and reinstalled the realtek drivers to be on the safe side.   Need a bit longer to see if its stable now before reintroducing amp (have lost 5.1),  but seems a stable at least.
Logged
Pages: [1]   Go Up