INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Gizmo Access to Library Server  (Read 5544 times)

PAR57

  • Recent member
  • *
  • Posts: 35
Gizmo Access to Library Server
« on: August 24, 2015, 09:59:55 am »

I have been using Gizmo successfully for weeks. Suddenly I cannot get Gizmo to access my MC20 server. When I open Gizmo I get a request for a JRiver Library Server access key but no field is generated to enter my authentication password (as entered in the "network" page of MC20). The Gizmo installation instructions say I should have to enter this and the MC20 Network page also says that the password is mandatory for access. The correct Library Access Server key is entered in Gizmo but no access is allowed.

I have now installed Gizmo on to a second Android device and have exactly the same experience ( this was an installation on a dvice that has never had Gizmo installed before, so I definitely should be asked to enter a password) i.e. only correct Library Server access key is requested ( and entered) but no password is sought by the app.

How can I remedy this and use Gizmo again?
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71458
  • Where did I put my teeth?
Re: Gizmo Access to Library Server
« Reply #1 on: August 24, 2015, 11:10:37 am »

It could be a change in your network.  Anything new?

If not, power everything down and back up, including your cable modem or equivalent, router, etc.

Make sure Wi-Fi on the phone is turned on and that you have Internet access.
Logged

PAR57

  • Recent member
  • *
  • Posts: 35
Re: Gizmo Access to Library Server
« Reply #2 on: August 24, 2015, 12:03:03 pm »

Many thanks for your response but I have done all of that . The wifi and router have to be working OK or I wouldn't have been able to read your response nor could I post this reply. I am writing on the same PC that is the MC20 server. My network is the same as it has been for the past several years, nothing new. Both Android devices ( tablet and phone) have working internet access via the network wifi.

My simple question is : Should Gizmo have a field for me to enter my authentication password when it is opened ?  The Gizmo instructions say that there should be such a field. If so it may be that it appears only upon first use and is saved so as to be invisible for later accesses ( with only the library server access code asked for). However such a field has never appeared at all recently on either of my Android devices both having recent (within the last couple of weeks) installations of Gizmo.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71458
  • Where did I put my teeth?
Re: Gizmo Access to Library Server
« Reply #3 on: August 24, 2015, 12:07:00 pm »

Many thanks for your response but I have done all of that . The wifi and router have to be working OK or I wouldn't have been able to read your response nor could I post this reply.
I don't think you can count on that.

Yes, there should be a password.  If you have successfully entered the user name and password once, you should not be asked again.

On your server, you could turn Media Network off and back on and set it up again.
Logged

PAR57

  • Recent member
  • *
  • Posts: 35
Re: Gizmo Access to Library Server
« Reply #4 on: August 24, 2015, 05:23:24 pm »

Thank you again. No result . So let's see what I have done:

1. Rebooted router/wifi.
2. Installed completely new copy of MC20 on server. Set new DNLA access with new Library Server Access code generated.
3. Set authentication password same as I believe was used before which should match that held in the installations of Gizmo or at least one of them ( see 4).
4. Installed Gizmo on device that has never has Gizmo installed before . Only field to enter Library Server Access code was generated.
5. Uninstalled Gizmo on device used previously. Installed new copy of Gizmo. No field for authentication passworrd generated, only Library Server Access code requested.
6. New library server access code from new installtion on server correctly entered on both Gizmo installations.
7. Checked that  server and all devices with Gizmo can access shared wifi network.
8. Checked "whitelist" in Windows Defender and McAfee (running on server machine) that JRiver MC 20 is included.
9. Checked if removing anti-virus software on Android devices helps. No difference.


Why do I not see any field to enter authentication password on either Android device that has Gizmo installed including one that has never had Gizmo installed before? If there IS a password stored on the devices with Gizmo and it doesn't match the one set in the server how can it be reset as there is no configuration menu in the Gizmo app?

Any ideas?
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: Gizmo Access to Library Server
« Reply #5 on: August 24, 2015, 05:32:07 pm »

On my version of Gizmo, I can do the following to enter new server information:

1.  Click in the vertical ... in the upper right to display a menu.
2.  Click Mode on that menu to get a new menu.
3.  On the new menu, choose from servers I've entered before, or click on New Server to enter new info.

Maybe that will get you some results?  I know very little about Gizmo.  Good luck.

Brian.
Logged

PAR57

  • Recent member
  • *
  • Posts: 35
Re: Gizmo Access to Library Server
« Reply #6 on: August 24, 2015, 05:58:45 pm »

Thanks blgentry for your interest.

My Android copies of Gizmo have no access to any menus. There is nothing to click on at all at the right vertical. All that the opening page has is :

1. Top left " Gizmo Connect to a server"
2. Centre top :" Enter a JRiver Library Server Access key". Three fields; blank ( to enter the code), "Go" and "Help".
3. Below 2. a graphic of the touching hands of God and Adam from Michelangelo's Sistine Chapel fresco.
4. Below 3. "GIZMO You're on the bus"

That's it.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: Gizmo Access to Library Server
« Reply #7 on: August 24, 2015, 06:09:30 pm »

Your #2 box is where you enter the Media Network authentication key.  This is the same key you'll find in MC under:
Tools > Options > Media Network > Access Key

Note this is different than "authentication", which is right below the access key on that same menu.  As far as I know, Gizmo only uses the Access Key, not Authentication.

Brian.
Logged

PAR57

  • Recent member
  • *
  • Posts: 35
Re: Gizmo Access to Library Server
« Reply #8 on: August 24, 2015, 06:43:12 pm »

Thanks again Brian.

However I am entering the Library Srver Acess key ( code) in box #2. All I see are unsuccesful attempts to access the server.

The instructions for setting up Gizmo say ( numbers 2 and 3) " You are entering a login name and password that will later be entered on the phone.

Step number 6. Once you eneter the key you will be asked for a login and password. These are the same as you entered on the pc in step 3 above.

OK I have done steps 2 and 3. Step 6 doesn't happen as there is no  connection recognised between Gizmo and the pc. That is using 2 different Android devices and two fresh MC 20 installations and DNLA network setups.NB: I have been using Gizmo succesfully for weeks previously so I must have had it set up correctly. It suddenly ceased to work and I cannot get any positive result despite all of the efforts I listed above.
Logged

PAR57

  • Recent member
  • *
  • Posts: 35
Re: Gizmo Access to Library Server
« Reply #9 on: August 24, 2015, 08:31:46 pm »

I have found the answer. Anti-virus ( McAfee) must have been updated and since then the firewall is blocking the Gizmo access to the library server. Turning off the firewall solves the problem. I will try to find a more permanent remedy.

Thanks to you guys for your helpful suggestions.

Pete
Logged
Pages: [1]   Go Up