INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: MC25 hangs whenever I start Media Network [Solved]  (Read 648 times)

bollada

  • Member
  • *
  • Posts: 4
MC25 hangs whenever I start Media Network [Solved]
« on: November 20, 2019, 02:49:42 pm »

Hope you can help. Here's the detail:
Version 25.0.114 (64 bit) on a Win 10 machine
Everything works perfectly until I try to start the Media Network - in order to use JRemote.
It works for just a few seconds and then hangs, I cannot do anything other than a force quit.
I have tried uninstall/reboot/re-install, starting from scratch with a very small library. Same, numerous times.
I have checked the Windows firewall settings and indeed MC25 is permitted through.
I re-installed MC23, started the server and it all works just fine, remote server and everything. Uninstalled 23, tried again with 25, no joy.
Looked to uninstall anti-virus but it's the Win 10 standard defender, and not sure I can remove it. It made no difference when I tried a temporary disable.
Any thoughts?  Thanks, John.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71603
  • Where did I put my teeth?
Re: MC25 hangs whenever I start Media Network
« Reply #1 on: November 20, 2019, 02:57:03 pm »

Try configuring Windows Defender.  There's a thread on it here.
Logged

bollada

  • Member
  • *
  • Posts: 4
Re: MC25 hangs whenever I start Media Network
« Reply #2 on: November 21, 2019, 05:43:17 am »

Thanks JimH - took a bit of finding, and it did give some useful hints.
It's here if anyone else is searching: https://yabb.jriver.com/interact/index.php/topic,114101.0.html
I did the Defender folder exclusions, the media network file exclusions and also separately found some additional media network processes in Firewall to exclude.
Initially none of this worked - and yes I rebooted many times.
But then.... I just switched defender off from real time protection, and it started working again!
Then switched it on again, and it just stayed working.  Rebooted and it stayed working still.
I'm not really sure I know which action fixed it - but now touching nothing else.
Logged
Pages: [1]   Go Up