INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5   Go Down

Author Topic: NEW: Blu-ray Menu playback support  (Read 58089 times)

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71654
  • Where did I put my teeth?
Re: NEW: Blu-ray Menu playback support
« Reply #100 on: August 16, 2018, 07:00:40 am »

Hendrik is away from his desk this week.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #101 on: August 16, 2018, 07:02:28 am »

Thanks - I saw that.  Hope he is having a good Vacation.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #102 on: August 20, 2018, 05:29:18 am »

Mmmm.  Copying just about any other MPLS to 00099.mpls will work and playback will be fine but none of them are the "right" one.  00000.mpls is the one that does the initial language selection but if I rename that one there is no ability to navigate and select the language.  If I use another then (say 00002.mpls) then it will play but skips the initial lang selection but does get to the main menu.  So for me it is "fixed" copying 00002 --> 00099.mpls but I don't think it is "correct".

My copy of Star Trek Beyond on UHD exhibits the same problem, so thats good. The file is definitely missing, but maybe it should just skip that title and continue. Will have to check on that.
Logged
~ nevcairiel
~ Author of LAV Filters

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #103 on: August 20, 2018, 05:37:44 am »

All three of the just released Avengers UHD do the same (weird) thing.  The first time you play these discs it asks for the Disc Lang, you select it (English for me) just fine but it then stalls and does not progress to the main menu.  If you stop and play it a 2nd time, it has remembered the Disc Lang and the main menu loads and it all works from there.

Mine does that too. Not sure whats wrong with this. Maybe something missing for UHD support. It is ultimately still "experimental" :)
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #104 on: August 20, 2018, 06:01:54 am »

:) pretty solid for "experimental" ... more some rough edges!  I've now got some 130 UHD and most are good to go.

Edit - Hope you had a good week off!
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #105 on: August 20, 2018, 08:36:24 am »

My copy of Star Trek Beyond on UHD exhibits the same problem, so thats good. The file is definitely missing, but maybe it should just skip that title and continue. Will have to check on that.

Made this work by resuming the HDMV execution if playing a title fails. Seems to fix this disc nicely.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #106 on: August 20, 2018, 11:51:40 pm »

Nice - surprised that HDMV helps on UHD, I thought they were all 100% BD-J?
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #107 on: August 21, 2018, 01:56:40 am »

Nah they are typically a mix, on simple titles the initial part is HDMV and BD-J is for the menus and the main title.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #108 on: August 21, 2018, 03:54:26 am »

Thanks... makes sense, use HDMV so users can pick the Menu Language then BD-J for the actual Main Menu etc.  Did it also fix the Avengers?
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #109 on: August 23, 2018, 03:29:19 am »

Confirmed that Star Trek Beyond is fixed.  No change to the Avengers oddness for me.
Logged
JRiver CEO Elect

Dekyon

  • Recent member
  • *
  • Posts: 14
Re: NEW: Blu-ray Menu playback support
« Reply #110 on: August 27, 2018, 05:30:04 am »

I have some problem using blurays decoded with AnyDVD HD, the "speed menu" function do not show text, only the background picture. This come form 24.0.46.
Logged

gonca

  • Recent member
  • *
  • Posts: 17
Re: NEW: Blu-ray Menu playback support
« Reply #111 on: August 28, 2018, 07:10:33 am »

Confirmed that Star Trek Beyond is fixed.  No change to the Avengers oddness for me.
I am having the same issue on some discs.
Changing the video from custom to Red October HQ seems to help, for now
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #112 on: September 02, 2018, 03:32:55 am »

I see there has been a bit of activity on the libbluray git in recent days. 
Logged
JRiver CEO Elect

gonca

  • Recent member
  • *
  • Posts: 17
Re: NEW: Blu-ray Menu playback support
« Reply #113 on: September 03, 2018, 02:44:43 pm »

Just a follow up
Seems that my problem was being caused by a leftover from an old installation
Self inflicted
Logged

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #114 on: September 08, 2018, 11:20:45 am »

FYI - One great thing about using the BD Menu is you get Forced Subs automatically without having to "find" the right sub stream.  Love it!

I can't get forced subs to work for UHD.  Tried the Hunt for Red October.  Playback of the individual m2ts shows the forced subs but from menu playback does not.

Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #115 on: September 08, 2018, 04:21:48 pm »

Are you using the MC Shipped version of MadVR (there is a bug in the later versions of MadVR where subs don't show.  Madshi knows about it and it will be fixed in the next version).  Also to check you can try RO Std.
Logged
JRiver CEO Elect

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #116 on: September 08, 2018, 06:28:55 pm »

Are you using the MC Shipped version of MadVR (there is a bug in the later versions of MadVR where subs don't show.  Madshi knows about it and it will be fixed in the next version).  Also to check you can try RO Std.

i am not due to a bug in that version of madvr where editing profile names does not work correctly.  every key press causes the profile field to lose focus.  however i will back up current version and give it a try.

forced subs do work fine from mkv or m2ts file playback

Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #117 on: September 08, 2018, 06:53:01 pm »

The bug has a few manifestations, this one is the Subs when playing from the menu are actually drawn off the screen (if you make a wide window with the movie in the centre you will see it on the far right).  Subs reapear in the correct area if there is other OSD happening.  Anyway, madshi is aware of it and he says it will be fixed in the next release.  The new release looks like it will be ready soon - the work for HDR --> SDR is nearing a conclusion.

So for now.... pick your bug!
Logged
JRiver CEO Elect

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #118 on: September 08, 2018, 07:38:01 pm »

Seems using the shipped version of madvr with MC v24 fixed the forced subs :)

The other nag I have with it editing profile names I can live with since it's a set-and-forget type of operation.

Thanks for the info re: the defect.

--
Logged

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #119 on: September 11, 2018, 05:32:58 pm »

Has anyone noticed any lip-sync issues with playback?

At least on two movies, the extras for Deadpool 2 and Clear and Present Danger I have to set the offset to -120ms for audio and video to sync.

Interestingly the movie playback seems fine.  I'll test some more.

BTW - this feature has me watching Extras again.  Amazing how lazy I've become that I can't just pop the disc into the player ;>)

Logged

If6was9

  • Recent member
  • *
  • Posts: 24
Re: NEW: Blu-ray Menu playback support
« Reply #120 on: September 18, 2018, 04:36:48 am »

Unfortunately it does not work with the menu of the calibration BD Ted's LightSpace CMS Calibration Disk,
it's a real shame, because I've always used it with all the players (TMT and PDVD)  :-\
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #121 on: September 30, 2018, 08:12:09 pm »

FYI Solo UHD showed the same behaviour as on some other UHD Discs were the initial Pre Menu "Disc Language" menu will let you select the Lang to use but it then does not progress to the Disc Menu.  2nd Playback is fine (as you go straight to the Disc Menu).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #122 on: November 29, 2018, 04:32:15 am »

There have been reports of ATMOS drop outs with Incredibles 2 (another Disney Title), and I've got the Oz UHD Version and can confirm that at around 3:16 there is a drop out, but it is a bit different than last time.  While the drop out is brief (my AVR GUI shows it as well) and is 100% repeatable if playing from the beginning, if you do a seek back it does not happen at the same spot.  I've attached a log that:
- Shows the drop out at 3:16
- A seek back after the drop out to before 3:16
- No drop out at 3:16

Thanks
Nathan
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #123 on: November 29, 2018, 04:33:25 am »

FYI Solo UHD showed the same behaviour as on some other UHD Discs were the initial Pre Menu "Disc Language" menu will let you select the Lang to use but it then does not progress to the Disc Menu.  2nd Playback is fine (as you go straight to the Disc Menu).
FYI - Incredibles 2 also shows this issues (among a bunch of others).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #124 on: November 30, 2018, 02:50:50 pm »

Watched UHD Incredibles 2 all the way through last night, bitstreaming ATMOS in Title Mode.  Lots of short drop out.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #125 on: December 07, 2018, 05:16:27 am »

Any thoughts on these drop outs?  Is is just a bad disk?
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #126 on: December 09, 2018, 12:35:11 am »

How good is the BD Menus!   ;D  I got a UHD BD of Westworld Season 2 and these discs are a pain to work out what MPLS = What Eps as they don't seem to follow any order that makes senses.  Not to worry, as fired each disc up with Menu Support, and using the BD Pop Up Menu selected each eps and noted down the Duration in the MC Playback Header.  When I then created the BD Particles it was easy to tag each one with the correct EPS # then do a Lookup of the TV Info.  Job done and it the correct order!  Love it!
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #127 on: December 09, 2018, 12:53:51 am »

Also got Sherlock on UHD and the Beeb has done a 50i--> 23.976 conversion on it.   :'(  Quick look on the into and you can see the judder this has introduced (where the Ferris Wheel goes round) but you don't notice it as much during the actual EPS.  What a shame.
Logged
JRiver CEO Elect

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #128 on: December 10, 2018, 04:44:15 pm »

good to know regarding westworld season 2.  mine just arrived and i have not ripped it yet.

you should see the mess fox did with fringe by the way.  earlier seasons are all one m2ts file per disc and not separate by episode.   i had to split them into episodes at the time with mkvtoolsnix. 

ó

iíve been very happy with the menu support so far!

Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #129 on: December 13, 2018, 04:06:52 am »

FYI - If you select the Rip in MC then Right Click --> Stacks --> Advanced --> Auto Create BD/DVD Title Particles, MC will add to your library an entry for every Playlist, and there will be one for each Eps (MPLS).  Once you work out which one is what EPS you can tag them up and update the info using "Get Movie and TV Info".  Ideally, once there are more Options in "Convert Format" you could then mux them out to MKV for each eps if you want .... but for me these particles just work for both MC playback and also clients.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #130 on: December 13, 2018, 02:52:31 pm »

There have been reports of ATMOS drop outs with Incredibles 2 (another Disney Title), and I've got the Oz UHD Version and can confirm that at around 3:16 there is a drop out, but it is a bit different than last time.  While the drop out is brief (my AVR GUI shows it as well) and is 100% repeatable if playing from the beginning, if you do a seek back it does not happen at the same spot.  I've attached a log that:
- Shows the drop out at 3:16
- A seek back after the drop out to before 3:16
- No drop out at 3:16

Thanks
Nathan

FYI - Seen a few other posts with conflicting info, but for me at least, the drop outs only happen with bitstreaming from LAV.  No drop out at the 3:16 point with decoding from MC, or when bitstreaming from a XBOX One S. 
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #131 on: December 14, 2018, 05:28:41 am »

How about in menu mode? That uses an entirely different demuxer afterall.
Logged
~ nevcairiel
~ Author of LAV Filters

SamuriHL

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1034
Re: NEW: Blu-ray Menu playback support
« Reply #132 on: December 14, 2018, 11:52:39 am »

My ripping tool of choice has been updated today with the following fix:

- fix: more sub version of Dolby Atmos are supported

I'm re-ripping Incredibles 2 UHD to MKV as we speak and plan on testing it again.  One thing I can try when that's done if there's still audio issues is to play the same MKV with my SHIELD and see if it has the same problem.  Would like to rule out LAV if possible.

EDIT:

Finished the rip and played in MC.  Several audio drops and finally lost audio completely just before the hover train scene.  SIGH.  I'll play on the SHIELD and see if it's any different there.

EDIT 2:

Alright, sorry Hendrik, but, this is without a doubt a LAV issue.  I am playing the exact same MKV on my SHIELD and not one audio drop even through the hover train scene where it completely dropped audio in MC.  Something's not right.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #133 on: December 14, 2018, 02:45:55 pm »

How about in menu mode? That uses an entirely different demuxer afterall.

Retested using a Folder Rip. 
- The 3:16 Drop out Only happens when Bitstreaming and happens in both Title and Menu mode. 
- There is No 3:16 Drop out in either Title or Menu mode when Decoding.
Logged
JRiver CEO Elect

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #134 on: December 14, 2018, 08:00:53 pm »

i can also confirm dropout while bitstreaming. decoded works fine

this was from an mkv

Logged

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #135 on: December 15, 2018, 09:13:58 am »

Different topic:

I was playing back via BluRay Menu Steven Wilson's Home Invasion concert.

I played an interview with him and subtitles were stuck on.  No way to disable them.

Checked in my Oppo player and the sub track is not on by default.

Anything I can provide to help with this?

thanks
Logged

audioriver

  • Citizen of the Universe
  • *****
  • Posts: 506
Re: NEW: Blu-ray Menu playback support
« Reply #136 on: December 16, 2018, 07:19:34 am »

Menus have been working great for me. Only issue remains the inability to select audio/subtitles during playback, PUO-permitting of course (prohibited user operations).

Not all discs provide a quick pop-up menu to make selections on the fly unfortunately.
Logged
Windows 10 Pro x64

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #137 on: December 16, 2018, 07:40:41 am »

is that why i canít disable subs?  maybe that is buried back in this thread.

odd the subs turn on by default though

Logged

audioriver

  • Citizen of the Universe
  • *****
  • Posts: 506
Re: NEW: Blu-ray Menu playback support
« Reply #138 on: December 16, 2018, 11:05:14 am »

You should be able to disable them from the disc's menu (subtitles=off/none), and then start playback. If not, something else is going on.
Logged
Windows 10 Pro x64

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #139 on: December 16, 2018, 02:00:29 pm »

No idea why it would have been ON (or forced ON) by default as I don't have that disc, but may be able to turn it off in the BD Menu (or Pop Up).  Also depending on your ripper you have "Remove prohibited user operations" option (eg AnyDVD has this option).  That said I'm not sure that libbluray even bothers reading or enforcing the PUO flags (Hendrik may know).
Logged
JRiver CEO Elect

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #140 on: December 19, 2018, 01:44:56 pm »

So it was "pilot error":

When setting up the "Audio Options" from the menus, after selecting the audio format I want, it immediately highlights the first subtitle (English) under the Subtitles options.

Was not paying attention and selected English instead of "Off" which was at the bottom of the list.

So while I was unable to disable after playback, subtitles are indeed not "stuck on" by default.

All is well :)

On a side note - highly recommend anything by Steven Wilson
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #141 on: December 19, 2018, 02:33:32 pm »

PEBCAK :) and we all do it.  I've sent Hendrik on may wild goose chases during the testing.  Glad it is sorted.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #142 on: December 21, 2018, 04:11:37 pm »

Hi Hendrik, any luck with the drop outs on Incredibles 2 or do you need any more test, logs, samples etc?
Logged
JRiver CEO Elect

thezone

  • Galactic Citizen
  • ****
  • Posts: 257
Re: NEW: Blu-ray Menu playback support
« Reply #143 on: January 01, 2019, 12:18:50 am »

Hi guys,

Does this function support playback of alternate angles?

I have the Police Bluray concert and in the pop up menu I can select the alternate angle button (for 2 songs on the disc that have alternate angles) but it does not invoke same, just continues to play the main track (view). 
Logged

TheShoe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 810
Re: NEW: Blu-ray Menu playback support
« Reply #144 on: January 04, 2019, 12:03:14 pm »

i have no idea.  will try to find a movie i have to see if it does.  i am still in the process of re-ripping discs to folder backups.   will look for one with multiple angles

there are at times some strange issues where for example my xfiles season 2 rips the extras have video playback in ff but the audio is normal



Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14277
  • I won! I won!
Re: NEW: Blu-ray Menu playback support
« Reply #145 on: January 04, 2019, 05:02:26 pm »

I was trying to find a movie in my collection with Angles but could not find a list of what discs have them, and I don't have the Police Bluray.  What I was going to do was:
- Reset Log,
- Play BD
- Change Angle
- Look at the log to see what (if anything) libbluray did.

If you like you could do the above and post your log.

Thanks
Nathan
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10785
Re: NEW: Blu-ray Menu playback support
« Reply #146 on: January 04, 2019, 06:02:14 pm »

I may have such a disc. I believe it's used in language choice for discs where the movie itself has varying segments for languages, ie. Big cinematic intros that are translated. I think Despicable Me and Minions did that, on international discs anyway. Might try to dig such a disc up.
Logged
~ nevcairiel
~ Author of LAV Filters

musicdeal

  • Member
  • *
  • Posts: 4
Re: NEW: Blu-ray Menu playback support
« Reply #147 on: January 09, 2019, 01:19:33 pm »

Hi When I try to play a BR with the menu the program crash

It said Adding Required components and nothing happend.

Could you help me ?

Thanks
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7463
  • When Summer comes...
Re: NEW: Blu-ray Menu playback support
« Reply #148 on: January 09, 2019, 01:40:31 pm »

Sounds like MC can't download the required components (LAV, madVR). You might check your firewall, as that's something that can cause the download to be blocked.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2024 Update (24H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/500GB M.2 NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | JBL 306P MkII Studio Monitors | Audio-Technica ATH-M50x Headphones

musicdeal

  • Member
  • *
  • Posts: 4
Re: NEW: Blu-ray Menu playback support
« Reply #149 on: January 09, 2019, 02:29:15 pm »

Sounds like MC can't download the required components (LAV, madVR). You might check your firewall, as that's something that can cause the download to be blocked.

Thanks a lot it's working fine now
Logged
Pages: 1 2 [3] 4 5   Go Up