INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: UPnP Plug-In 1.0.10 for Media Receivers  (Read 24553 times)

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
UPnP Plug-In 1.0.10 for Media Receivers
« on: January 31, 2005, 02:08:20 pm »

MC's UPnP Server is available here:
http://www.jriver.com/~gateley/server_upnp1010.mjp
This is for Media Center 11 only.

Changes and fixes
1) Support for D-Link DSM320  (better object class definitions).  Limited to music at this time, but we plan to add image playback soon.
2) Added resource size attribute.
3) Fixed resource duration attribute to be the correct format.

--------------------------------------------------------

Instructions for using the UPnP Server
Click on Plug-ins in MC's tree, then on UPnP Server.  On the right side of the UPnP Server page, set "Options" and then click on "Start" to start the server.

If a media receiver is already on the network, and the server is started, the receiver should pick up the server right away. When a media receiver is first turned on, if the server is already started, the receiver should pick up the server. Some receivers may not do both correctly, so try both.

If you cannot see your view scheme, make sure that:
1) The View Scheme is selected to Show in Theater View (under Edit View Scheme).
2) The View Scheme is a child of "Audio", "Images" or "Video".

Options
You can convert files to MP3 as they are streamed.  See Options on the UPnP page.

If you have multiple network interfaces on your computer, such as an ethernet and a bluetooth interface, you may need to specify the IP address the UPnP server uses (it will only listen on a single interface, and may choose the one the device is not on).

Unless you are reporting log information here, you can turn off many warings by unchecking "Warn on unrecognized NOTIFY".

Checkboxes are available for three special cases:

1.  "Replace Empty Genre" is required for the NETGEAR MP101, and possibly others. It replaces blank genres with "Unknown". The MP101 will otherwise refuse to play tracks with blank genres.

2.  "Use Flat URLs" is required for the SMC EZ Stream and the Terratec Noxon. These receivers cannot handle complex URLs (internal to the protocol) and this hack changes the URLs to simpler ones.

3. "Include SessionID" must be turned off for Roku. It may be required for others. If you know of a device that requires it, please let me know.

A log is generated on the UPnP Server page in MC.  If you have a UPnP device that doesn't work, you can copy the log from MC's UPnP Server (under the tree/plug-ins) and paste it into a thread here. Make sure the "Warn on unrecognized NOTIFY" option is selected before creating the log.

A thread that explains more about UPnP and how MC supports it:
http://yabb.jriver.com/interact/index.php?topic=25689.0

Supported UPnP Devices are here:
http://yabb.jriver.com/interact/index.php?topic=25839.0

The previous thread on the UPnP Server:
http://yabb.jriver.com/interact/index.php?topic=25798.0

twentworth22

  • Regular Member
  • Recent member
  • *
  • Posts: 45
  • nothing more to say...
Re: UPnP 1.0.10 for Media Receivers
« Reply #1 on: January 31, 2005, 08:02:09 pm »

My DSM-320 works now!  Nice job!!!!

I've been in computer software for 15 years in various engineering/PM roles and I have to say you guys are the most customer friendly software company I've had the pleasure of working with.

Keep up the great work,
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71768
  • Where did I put my teeth?
Re: UPnP 1.0.10 for Media Receivers
« Reply #2 on: January 31, 2005, 09:18:32 pm »

Thanks.  We rely on the information we receive from people like you. 
Logged

godavego

  • Regular Member
  • World Citizen
  • ***
  • Posts: 130
  • Change this by choosing profile
Re: UPnP 1.0.10 for Media Receivers
« Reply #3 on: February 01, 2005, 08:55:26 am »

I tried 1.0.10 with my Roku SoundBridge M500 last night, and it worked.  However, there were a few issues.

1. Why show the ability to browse pictures?  Is that a limitation of UpnP?

2. When using Windows Media Connect as the server, I can press play at any point and all songs matching the criteria will be played (Play Blues, for example).  With MC, I can't hit play till I get all the way to the individual song.

3. WMA Lossless doesn't seem to work.  I have to convert to MP3.  It's possible that Windows Media Connect is doing some automatic conversion, but I certainly didn't have to setup anything.  I looked around WMC, and I didn't even see an option for converting.

4. Is converting to WMA an option?

Thanks for a wonderful addition.  I'm looking forward to MC11 getting out of Beta, so I can add this to my main system.
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP 1.0.10 for Media Receivers
« Reply #4 on: February 01, 2005, 09:59:43 am »

The picture browsing is difficult: some devices want them and some don't, and I don't think this desire is communicated via the protocol in any way. I'll double check this, but probably I'll just make it an option - music only, or entire database.

The "play" feature - this is implemented on the Roku in a way I don't handle yet. It's on my list.

WMA lossless - known issue, on my list.

Converting to WMA is not currently an option, but could be if there's enough desire...

j


godavego

  • Regular Member
  • World Citizen
  • ***
  • Posts: 130
  • Change this by choosing profile
Re: UPnP 1.0.10 for Media Receivers
« Reply #5 on: February 01, 2005, 10:52:27 am »

I figured the protocol wasn't specific about the pictures.  It isn't a big deal, especially if you add an option to not publish them.

The "play" and WMA Lossless features would be huge for me.  I thought I read somewhere that the Roku was telling WMC to do some form of conversion, but there were no details.  Like I said, WMC has no conversion option.  I know the Roku is one of the few that support WMA Lossless, and this was a large part of why I bought it.  I currently have about 250Gig of WMA Lossless files, and I didn't want to have to convert them or maintain two copies of everything.

I'm not too concerned about converting to WMA.  I was just asking.

One more question - With this support multiple players?  I only have one Roku now, but I'm planning on adding at least one more in my kid's playroom.

Thanks again!
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71768
  • Where did I put my teeth?
Re: UPnP 1.0.10 for Media Receivers
« Reply #6 on: February 01, 2005, 01:31:57 pm »

We just added a page that summarizes the extent of our support for UPnP devices right now.

http://yabb.jriver.com/interact/index.php?topic=25839.0
Logged

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #7 on: February 01, 2005, 03:36:00 pm »

I've just bought a Streamium 300 on the strength of these posts!
So far so good ... it works!

I'd vote (twice) for the ability to play an entire album, genre, etc with one click
Logged

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #8 on: February 01, 2005, 03:43:36 pm »

The "specify IP Address" option on the Server Options Page...

Is this intended for the target device's IP address?
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #9 on: February 01, 2005, 03:45:38 pm »

No - it is to specify the IP address for the server to listen on. Some servers have multiple ip addresses (like with an ethernet interface, a wireless interface and a bluetooth interface all on the same machine). The server needs to know which interface/IP address to listen on (not just to listen, but so that it can send the appropriate IP address to the player).

j

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #10 on: February 01, 2005, 03:52:51 pm »

Thanks John
Logged

bshock

  • Regular Member
  • Recent member
  • *
  • Posts: 9
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #11 on: February 03, 2005, 10:54:32 pm »

Omnifi DMS1 results
(these look familiar)

02/03/05 22:46:43 - JRiver UPnP Server Version 1.0.10 starting...
02/03/05 22:46:43 - Server running on address 192.168.1.100, port 3845
02/03/05 22:46:43 - Running
02/03/05 22:46:45 - Received request for device description
02/03/05 22:46:47 - Received request for device description
## No dice, DMS1 rebooted here
02/03/05 22:50:43 - Unknown SSDP Server method: NOTIFY, NT: upnp:rootdevice, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::upnp:rootdevice
02/03/05 22:50:43 - Unknown SSDP Server method: NOTIFY, NT: upnp:rootdevice, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::upnp:rootdevice
02/03/05 22:50:43 - Unknown SSDP Server method: NOTIFY, NT: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29
02/03/05 22:50:43 - Unknown SSDP Server method: NOTIFY, NT: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:device:MediaRenderer:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:device:MediaRenderer:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:device:MediaRenderer:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:device:MediaRenderer:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:RenderingControl:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:RenderingControl:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:RenderingControl:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:RenderingControl:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:ConnectionManager:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:ConnectionManager:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:ConnectionManager:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:ConnectionManager:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:AVTransport:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:AVTransport:1
02/03/05 22:50:44 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:service:AVTransport:1, USN: uuid:Omnifi-DMS1-000000000000001460503562-1000000449-29::urn:schemas-upnp-org:service:AVTransport:1
02/03/05 22:50:49 - Received request for device description
02/03/05 22:50:52 - Received request for device description
02/03/05 22:51:44 - Received request for device description
02/03/05 22:56:44 - Received request for device description
02/03/05 23:01:44 - Received request for device description
Logged

MartinD

  • Recent member
  • *
  • Posts: 12
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #12 on: February 05, 2005, 05:09:44 am »

Hi,

I'm still having timing issues with my Noxon. Simple View Schemes (like Grouping/Artist/Album) work, but when I'm accessing more complex schemes which take a little bit longer to show up (e.g. pick files from a smartlist which builds up from other smartlists), the Noxon jumps back to start.

I'll report this to Terratec, maybe they can help...

-Martin
Logged

MartinD

  • Recent member
  • *
  • Posts: 12
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #13 on: February 05, 2005, 06:16:48 am »

Hi,

when audio conversion is enabled, the Noxon does not show artist/album infos (only track name)... this is not the case when audio conversion is off.

-Martin
Logged

twentworth22

  • Regular Member
  • Recent member
  • *
  • Posts: 45
  • nothing more to say...
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #14 on: February 11, 2005, 03:02:48 pm »

Updating to the latest DSM-320 firmware broke MC.  I now get the following messages that loop over and over again when I try and play any file.

Quote
02/11/05 15:59:51 - Received request for file: C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:51 - Sharing (without conversion): C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:51 - Received request for file: C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:51 - Sharing (without conversion): C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:51 - Received request for file: C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:52 - Sharing (without conversion): C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3
02/11/05 15:59:52 - Received request for file: C:\Documents and Settings\twentwor\My Documents\My Music\Destiny's Child\Destiny Fulfilled\Destiny's Child - Destiny Fulfilled - 01 - Lose My Breath.mp3

The UPNP server from DLINK works fine.
Logged

matthewmattical

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 94
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #15 on: February 11, 2005, 05:10:06 pm »

I'm still not having any luck with my Linksys WMLS11B. I noticed this line in the 11.0.92 change log:
11. Fixed: UPnP Server supports better object types (required for LinkSys).

...but is that referring to Linksys routers?

Thanks!
Logged

raistlin2k

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 88
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #16 on: February 12, 2005, 12:42:55 pm »

Hi,

I'm still having timing issues with my Noxon. Simple View Schemes (like Grouping/Artist/Album) work, but when I'm accessing more complex schemes which take a little bit longer to show up (e.g. pick files from a smartlist which builds up from other smartlists), the Noxon jumps back to start.

I'll report this to Terratec, maybe they can help...

-Martin

I just received my Noxon, unfortunately, it doesn't even work with simple view shemes (like the default ones of MC like arist/album) because I seem to have too many files (200GB). I get timeout errors all the time (Noxon returns to main screen). Scenario: I have 50 compositions by Beethoven, selecting Beethoven as artist, it returns to Main screen after a while.

I tried with Musicmatch and no problems at all with the same files, browsing is much faster than with MC. Getting longer delay time before timeout by Terratec is the wrong way IMO. Please, try to speed up your UPNP Server Plugin. 

FAST Browsing with Noxon is impossible besides timeout errors, I guess any UPNP Device will profit from a faster browsing...

Thanks a lot for your efforts
Raist

P.S. I have noticed that it is impossible to remove the default view sheme groups like audio, image etc. from MC completely, although I deleted them, they appear on Noxon. Unchecking "Show in Theater View", they are still present on Noxon, any ideas why??

EDIT: One more issue: Unicode not working. albums with unicode letters cannot be accessed with Noxon like "Sonate fr Klavier und Violoncello A-dur op. 69", UPNP Server log delievers "02/13/05 18:09:07 - Browse BrowseDirectChildren Audio\Artist/Album\Beethoven, Ludwig van\Sonate fr Klavier und Violoncello A-dur op. 69
" Noxon jumps back to main screen. Please fix this as well
Logged

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #17 on: February 21, 2005, 11:21:43 am »

UPnP Plug-In 1.0.10 appears to work very well with my hard wired Streamium SL400i.  Great Job!  :D

Only one MAJOR problem:  I can't play my WAV files! :-[  When I try, the Streamium says it's an invalid format.  If I set the server to encode to MP3, I can play my files just fine.  Image files (JPG) work OK as well.

Is this expected or am I doing something wrong?

I bought ver 10 and I really like it.  I'd love to use your server (looks like the best one out there by far), but since all my files are in WAV format, it's currently of limited use for me.

Thanks in advance for any help....

P.S. Duplicate post, thought this would be a more appropriate place for the question.
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #18 on: February 21, 2005, 08:24:09 pm »

I think the WAV file problem is fixed. There is a known issue that I fixed last week with this. I haven't had a chance to test it yet, I'll know for sure soon.

j

raistlin2k

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 88
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #19 on: February 23, 2005, 02:55:26 pm »

I phoned today with Terratec, Company of Noxon:
1. They cannot use the alphanumeric remote control to jump to a specific letter in my long list due to too short RAM inside the Noxon.
2. They think they can increase the time before timeout, but I think this problem might be also related to the small RAM, perhaps it's not a kind of timeout, but too less RAM for browsing such a big DB.

Anyway, I'll return the Noxon to the store, cause it#s complete unusable for a big library.

Therefore, I have some questions to all UPNP users in here:

1. John, what about the unicode problem. Are you aware of it? Can you fix it?
2. Anyone here with a Netgear 101 or Roku M 500/1000/2000?
I read that with the Netgear and at least Firmware 1.36 you can use the alphanumeric remote control for jumping around in the list. The Rokus are supposed to jump to the next letter with the left/right control. Can anyone confirm that these functions work properly with Media Center 11? Especially for the Netgear, I read that it sometimes doesn't work.

I would be very happy about some recommendations, so that I don't buy a not properly working Hardware again.

THANKS A LOT
Raist
Logged

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #20 on: February 23, 2005, 03:05:17 pm »

Hi - I can't comment on the Netgear or the Roku but I have used a Philips Streamium SL300 and can report no problems other than being slightly slow for the full library (28000 tracks) compared go thhe Philips server withg the same number of tracks

It supports alphanumeric jumps and is very stable (touch wood!)

I haven't used MC for images or video as I used the Philips server for those

Good Luck
Logged

raistlin2k

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 88
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #21 on: February 23, 2005, 03:27:11 pm »

Thanks for your really fast reply. Unfortunately, the SL300 doesn't have a display.
I want to use the Media receiver without a TV attached, so from the Streamium line only the SL400 or SL50i (that's new, isn't it?!?) is suitable. Since I need only music, the SL50i should be right. Is this a full streamium device or only "half" like the MCW-770??

So the SL300 doesn#t cover my needs, but anyway THANKS A LOT, without you I wouldn't have noticed that there is a new one, the SL50i, which joins my list of usable players.

I guess a lot of users don't want to spend so much money if they only want it for music-listening, video part is useless, but an inbuilt display quite important.
Since Noxon is bit buggy, there are three devices left: Philips SL50i, Netgear MP101 and the Roxu M-500.
I hope that we will be able to find out which of these three is the best in conjunction with MC, so all users can profit from this comparison.

Thanks again
Raist
Logged

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #22 on: February 23, 2005, 09:30:11 pm »

So the SL300 works with alphanumeric jumps?

Wierd, since I tried this with my SL400i and it doesn't work.  These units are supposed to be based on the same hardware and firmware.

How about the shuffle function? - it doesn't work with my SL400i either.

If the MC11 UPnP server were to support these two functions along with WAV files I'd be one REAL happy camper....


As for the SL50i, I'd not recommend it.  It's hardware base is apparently entirely different from the 300 and 400 and it doesn't seem to get any support like the 300 and 400.  It's also not on the list of "supported" players.

Check out the Streamium forum for a lot more info:  http://www.streamiumcafe.com/ubbthreads/ubbthreads.php
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #23 on: February 24, 2005, 06:45:44 pm »

The unicode bug is on my list, yes.

j

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #24 on: February 24, 2005, 07:55:15 pm »

The unicode bug is on my list, yes.

j


Excuse my ignorance, but what's unicode?  Is this the coding method used for entering text with a telephone-type keypad?
Logged

DWAnderson

  • Galactic Citizen
  • ****
  • Posts: 484
  • nothing more to say...
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #25 on: February 24, 2005, 09:37:51 pm »

Excuse my ignorance, but what's unicode?  Is this the coding method used for entering text with a telephone-type keypad?

Unicode is a method for storing text data in two-byte pieces, one two-byte peice for each character. This allows having 32,768 different characters.

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #26 on: February 25, 2005, 01:55:30 am »

So the SL300 works with alphanumeric jumps?

Wierd, since I tried this with my SL400i and it doesn't work. These units are supposed to be based on the same hardware and firmware.

How about the shuffle function? - it doesn't work with my SL400i either.
The alpha jumps works for me with the SL300 but not shuffle or repeat
I'm with you Myron - it'd be great if shuffle would work
Logged

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #27 on: February 25, 2005, 04:17:52 pm »

Just spent some more time trying out the UPnP server with my Philips SL400i and I'm liking it more and more.  However, I found a few more items that don't work properly:

- Fast forward, rewind and pause don't work while playing a track (stop and play are OK)

- Playlists point to the wrong track on the Streamium, but work OK on the PC (that is if I ask for song A on the Streamium it plays song X, but MC plays song A on the PC).

Anyone else seen this behavior?
Logged

benjamin00

  • Regular Member
  • Recent member
  • *
  • Posts: 23
  • I might be a porcupine.
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #28 on: February 26, 2005, 05:11:40 am »

This plug in seems really great, buti I can't use i don't have one the compatible product.
But i have a question mey be it can interest many people:
with this plugin don't you thing i can use a XBOX  rather one of this product.
I know you can use UPnP with a XBOX.

Can you tell me if it's possible?
Thanks for your help

Benjamin
Logged

evanr76

  • Regular Member
  • Recent member
  • *
  • Posts: 38
  • nothing more to say...
Buffalo LinkTheater
« Reply #29 on: February 26, 2005, 07:30:15 pm »

I am playing with Buffalo Technology's new media receiver, the LinkTheater.  This one upconverts to 1080i over component video and has 802.11b/g support built-in.

Good news:
The receiver recognized MC right off the bat and I was able to connect to it with no problems and see a root menu with Audio, Images, Video, Playlists (I am using default schemes, nothing special).

Bad news:
Browsing any of the folders I am not able to get past the 2nd level of any hierarchy.  For example, with audio, I can see a genre list but then when I pick a genre and I should see artists, there are no artists to choose from (or months, if I am browsing images and choose a year).  In all cases I just see a "back" link to the previous level.

I have tried with and without flat URL's.

Here is some relevant stuff from the log, browsing from the root to an audio genre node ("80's")

--
02/26/05 17:19:09 - JRiver UPnP Server Version 1.0.10 starting...
02/26/05 17:19:09 - Server running on address 192.168.2.203, port 2953
02/26/05 17:19:09 - Running
02/26/05 17:19:09 - Received request for device description
02/26/05 17:19:10 - Received request for service description
02/26/05 17:19:10 - Received request for service description
02/26/05 17:19:10 - Received request for device description
02/26/05 17:19:16 - Unknown SSDP Server method: NOTIFY, NT: upnp:rootdevice, USN: uuid:myiBoxUPnP::upnp:rootdevice
02/26/05 17:19:16 - Unknown SSDP Server method: NOTIFY, NT: uuid:myiBoxUPnP, USN: uuid:myiBoxUPnP
02/26/05 17:19:16 - Unknown SSDP Server method: NOTIFY, NT: urn:schemas-upnp-org:device:SyabasSTB:1, USN: uuid:myiBoxUPnP::urn:schemas-upnp-org:device:SyabasSTB:1
02/26/05 17:19:19 - Browse BrowseDirectChildren 0
02/26/05 17:19:22 - Browse BrowseDirectChildren 0
02/26/05 17:19:23 - Browse BrowseDirectChildren Audio
02/26/05 17:19:35 - Browse BrowseDirectChildren Audio
02/26/05 17:19:38 - Browse BrowseDirectChildren Audio80's
Logged

Marc

  • Regular Member
  • World Citizen
  • ***
  • Posts: 119
  • Filthy Monkey
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #30 on: February 27, 2005, 06:04:33 pm »

  Thank you, thank you, thank you! 

I'd been bitching about this for a while, but missed the initial roll-out.  Imagine my suprise when I discovered this thread buried and started reading.  Well, today I also discovered that my local Circuit City had NetGear MP101's on sale for $79.  I went down, snapped one of these up, updated the internal software, and now I'm enjoying 225+ GB of music in my garage shop!  Did I remember to thank you?  Makes the TiVo bug insignificant in comparison.

Anyways, I'm off to play with my new toy.  I'm really happy now...

Marc
Logged
THAT's what I'm talking about.

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #31 on: March 01, 2005, 11:06:38 am »

Hi Y'all,

I've got a new improved version of the UPnP Server ready to go, but for logisitic reasons, it's going to be a week or so before I can actually release it. Just wanted to let y'all know I'm still working on it.

j

raistlin2k

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 88
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #32 on: March 01, 2005, 11:10:28 am »

One week of waiting for that new version??

What a pity!!

That means 7 days of waiting... = 168 hours = 10080 minutes = 604800 seconds I have to count before I can test this new version.  :'(

Thanks
Raist  :D
Logged

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #33 on: March 01, 2005, 11:51:40 am »

Hi Y'all,

I've got a new improved version of the UPnP Server ready to go, but for logisitic reasons, it's going to be a week or so before I can actually release it. Just wanted to let y'all know I'm still working on it.

j


Thanks, I can hardly wait!  ::)

Can you give us any clues as to what's changed in the latest version?
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #34 on: March 01, 2005, 11:59:07 am »

A fix to the mime type problem, and a general upgrade of the transcoding feature.

j

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #35 on: March 01, 2005, 12:23:55 pm »

A fix to the mime type problem, and a general upgrade of the transcoding feature.

j


 :( Aw Rats!

I was hoping for WAV file support, navigation and shuffle improvements with the Streamium Sl400i.....

"Just spent some more time trying out the UPnP server with my Philips SL400i and I'm liking it more and more.  However, I found a few more items that don't work properly:

- Fast forward, rewind and pause don't work while playing a track (stop and play are OK)

- Playlists point to the wrong track on the Streamium, but work OK on the PC (that is if I ask for song A on the Streamium it plays song X, but MC plays song A on the PC)."

Thanks again anyway, and keep up the good work.
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #36 on: March 01, 2005, 01:11:24 pm »

WAV file support  IS the mime type problem :)
As for the rest, I've still got most of a week to go...

j

raistlin2k

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 88
  • Change this by choosing profile
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #37 on: March 01, 2005, 02:41:21 pm »

Please don't forget the unicode bug...

Thanks
Raist
Logged

marketability

  • Regular Member
  • World Citizen
  • ***
  • Posts: 177
  • eat!
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #38 on: March 01, 2005, 03:28:04 pm »

and my upnp server only makes cold coffee
I'd like hot cappucino! ;D
Logged

twentworth22

  • Regular Member
  • Recent member
  • *
  • Posts: 45
  • nothing more to say...
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #39 on: March 01, 2005, 05:20:32 pm »

WAV file support  IS the mime type problem :)
As for the rest, I've still got most of a week to go...

j


Any thoughts on why the DSM-320 firmware update broke your UPnP plug-in?  I had everything working perfectly for a week until the auto-update broke it!
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #40 on: March 02, 2005, 10:51:18 am »

No idea, can you past the log here?

j

Chili-Jam

  • Regular Member
  • World Citizen
  • ***
  • Posts: 107
  • same same ... but different
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #41 on: March 03, 2005, 05:38:28 am »

Hi,
i'm having a problem when browsing on my Roku:
<- Roku Reports: Failed to load browse data > OK <

My library has 12k files, 1k Albums.
It depends on my view schemes if i'm able to browse or not.
It only works if there is few data to browse.
I'm using a wired LAN connection.    

There's a thread about that problem:
http://yabb.jriver.com/interact/index.php?topic=26117.0

Any idea about that?

Thanks for the great work.
Logged

RedDom

  • Recent member
  • *
  • Posts: 20
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #42 on: March 03, 2005, 08:17:33 am »

I'm not sure if this is an issue to do with the U PnP server, the roku  or something else.
I have it working perfectly with my Roku by transcoding wma to mp3 (to reduce wireless bandwidth).  however I also have DAB digital radio reciever, that i am using with software called DABBAR, to stream across the network.  Dabbar provides me with a .m3u file that points to a stream on an http address that is my dabbar server.  The problem is that the stream is mp2  not mp3. 
When i try to use this in the roku, it seems like it is still mp2 that gets streamed (The Roku does not support mp2) its like the roku goes directly to the source of the stream, rather than jrmc, or that jrmc does not reencode the stream to mp3 from mp2.

On a seperate note, cpu usage when transcoding wma to mp3 is very high (80-90%), when compared to using slimserver (10%), doing the same thing.

Thx

RD
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #43 on: March 03, 2005, 10:20:25 am »

RedDom,

The next version may fix this problem. Right now, there's a problem with Mime types that makes non-mp3 stuff not work.

j

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #44 on: March 03, 2005, 10:22:30 am »

Chili-Jam - can you post the log? I'm not sure what's going on.

j

Robert Taylor

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 646
  • Living in a Smokeless Zone...
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #45 on: March 04, 2005, 01:44:09 am »

Gday,

I just bought an HP IPAQ RX-3115, which includes the NEVO universal remote software, and some stuff called "Mobile Media" which is made by the same people (http://www.mynevo.com).

The CD which comes with the IPAQ has it's own media server software, but on a hunch, I decided to see if it could see MC running uPNP server wirelessly off my laptop. It does!

That's fantastic, I can strap my IPAQ to my hat while I'm mowing, and stream music from the house...

Only thing I noticed was that there seems to be a location to display cover art on the IPAQ, but it's blank (it displays a default image).

Does the uPNP server support cover art? Or, is there something "non-standard" about this aspect of the IPAQ software uPNP implementation?

Not a biggie...
Logged
Cheers
Rob

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #46 on: March 04, 2005, 09:43:48 am »

Lunchmeat - cool!

We don't support cover art yet, it's on my list, but it's pretty far down...

j

Myron

  • World Citizen
  • ***
  • Posts: 220
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #47 on: March 04, 2005, 11:02:48 am »

Lunchmeat - cool!

We don't support cover art yet, it's on my list, but it's pretty far down...

j


Wow, support for cover art would be AWESOME!

Any idea as to what it might look like?  I'm guessing it could be similar to "Library View", but I don't really know what's possible within the UPnP framework. 

How about cover art support in custom views, which I haven't found to be implemented yet (or am I wrong)?

If it makes in difference I vote that this me moved up the list, immediately following basic navigation and playback "transport" functionality (FF, RW, pause, shuffle, etc).

Hoping the list starts shrinking real soon.....
Logged

Markeau

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 298
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #48 on: March 04, 2005, 03:23:49 pm »

Is there a list of UPnP media products that work the "best" with MC11?  I realize more and more bugs will get fixed but it seems like it would be great for us non-UPnP owners to be able to view a living list of the current most compatible products - I want to start adding some to my home.
Logged

Marc

  • Regular Member
  • World Citizen
  • ***
  • Posts: 119
  • Filthy Monkey
Re: UPnP Plug-In 1.0.10 for Media Receivers
« Reply #49 on: March 04, 2005, 06:19:23 pm »

The NetGear MP101 I bought last weekend has been working *perfectly* ever since.  I just wish the Media Server would run as a separate service so I don't have to worry about having MC up and running.  I just went with A).  One that was on "the list," and B).  What was cheapest ($79).

Good luck.  Mine rocks!
Logged
THAT's what I'm talking about.
Pages: [1] 2   Go Up