INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB  (Read 23985 times)

Fonzo

  • Recent member
  • *
  • Posts: 10

I'm currently using the latest trial-version of MC12 and the software is just brilliant and on this extensive forum I already solved a lot of small playback issues and codec settings. There is however a problem I cannot solve:

I connected a M-Audio Transit USB to my Sony DTS-receiver through optical SPDIF TOSlink. I use ffdshow from the latest CCCP codec-pack. When playing DTS-content from DVD in MC12 -such as Donald Fagen's Kamakiriad- the signal is passed-though correctly, using the "Dolby Digital/DTS pass-through 16-bit / 48000Hz" option in the M-Audio control panel and the ASIO playback setting in MC12 itself. The sound quality is absolutely stunning. :)

However, when playing .dts/.wav files, DTS-CD-images (on my hard disk as .cue with.wav files) or loaded in a virtual drive (.ngc and .img), the signal can only be played when selecting the "2-In/2-Out, 24-bit, 8000 48000 Hz" option in the M-Audio control panel. The output to the speakers is 5.1 and the receiver indicates DTS 3/2.1 output, BUT I noticed a quality difference between these two M-Audio control panel options mentioned above when playing DTS-DVD. Output though "pass-through" just sounds better. I already tried ASIO4ALL as alternative driver in MC12, but nogo. I also found some related topics on this forum: http://yabb.jriver.com/interact/index.php?topic=39539.0 and http://yabb.jriver.com/interact/index.php?topic=39200.0. I setup ffdshow correctly (I guess) using glynor's Wiki DTSWAV article: DTS (and AC3) are set to SPDIF, DSP inside MC12 is disabled. But there is no way I can use "pass-through" when playing .dts/.wav files or DTS-CD images. I assume the bitstream is handled by the M-Audio itself and send through SPDIF to my receiver, rather than passed-through and handled by the receiver itself which only works when playing DTS-DVDs. The latter sounds much better.

Any suggestions?
Logged

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #1 on: May 09, 2007, 06:04:58 am »

DTS audio CDs have the DTS signal coded inside standard 44.1 kHz/16-bit Red Book CD audio format. You should not let the output go through DirectShow filters that may alter or process the signal.

MC12 is capable of bit perfect 44.1 kHz/16-bit PCM playback (from wav or losslessly compressed files or from standard CD-audio). Inside MC you must disable everything that is related with DSP including the internal volume and replay gain adjustments.

An ASIO driver is needed for bypassing the Windows kernel mixer. Also the soundcard & its drivers must be capable of bit perfect 44.1 kHz pass through (but this should fine with the Transit).
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Fonzo

  • Recent member
  • *
  • Posts: 10
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #2 on: May 09, 2007, 11:56:18 am »

Thanks for your quick reply.

I already assumed I have to somehow bypass the DirectShow filters. Everything in DSP is already unchecked. 'System Volume' is selected in Player ==> Volume. I forgot to mention, when playing .dts and .wav files in combination with the M-Audio control-panel option "Dolby Digital/DTS pass-through 16-bit/48000Hz", MC12 pops up with the following dialog:

(1) "The ASIO device 'M-audio USB ASIO Interface' does not support the sample rate of 44100Hz".

Followed by:

(2) "Playback could not be started on the output 'ASIO using the format '32 bits Per Sample, 2 Channels'.
This output may not be supported by your hardware. You can use DSP Studio to change the output to a compatible format. Also, make sure that you system has a valid sound playback device and that it is properly configured in playback options."

And now it's getting rather interesting: when selecting the "ASIO4ALL v2" drivers instead of the "M-Audio ASIO Interface" in Outout Mode Settings, the two error messages above are gone. The .dts file is playing and I can see the Spectrum Analyzer bargraph. But alas, there is no sound an no DTS indication on my receiver.

I fiddled around with the Channel Offset settings and changed it from 1 to 6, but this only results in a dialog box which indicates 'ASIO Start Return Value: -1 (should be 0) and 'Plugin Open Return Value: -1 (should be 0)' folowed by the same second dialog box mentioned above (2).

Any clue?
Logged

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #3 on: May 09, 2007, 01:41:21 pm »

Thanks for your quick reply.

I already assumed I have to somehow bypass the DirectShow filters. Everything in DSP is already unchecked. 'System Volume' is selected in Player ==> Volume. I forgot to mention, when playing .dts and .wav files in combination with the M-Audio control-panel option "Dolby Digital/DTS pass-through 16-bit/48000Hz", MC12 pops up with the following dialog:

(1) "The ASIO device 'M-audio USB ASIO Interface' does not support the sample rate of 44100Hz".

Followed by:

(2) "Playback could not be started on the output 'ASIO using the format '32 bits Per Sample, 2 Channels'.
This output may not be supported by your hardware. You can use DSP Studio to change the output to a compatible format. Also, make sure that you system has a valid sound playback device and that it is properly configured in playback options."

And now it's getting rather interesting: when selecting the "ASIO4ALL v2" drivers instead of the "M-Audio ASIO Interface" in Outout Mode Settings, the two error messages above are gone. The .dts file is playing and I can see the Spectrum Analyzer bargraph. But alas, there is no sound an no DTS indication on my receiver.

I fiddled around with the Channel Offset settings and changed it from 1 to 6, but this only results in a dialog box which indicates 'ASIO Start Return Value: -1 (should be 0) and 'Plugin Open Return Value: -1 (should be 0)' folowed by the same second dialog box mentioned above (2).

Any clue?

Let's make one thing clear first. Are your files ripped from 5.1 DTS Music Discs ?
(- similar to these: http://www.5point1.com/Products-5_1_DTS_Music_Disc_2.html)

If yes, then you should not use anything that you would not use for bit perfect PCM 2-channel stereo playback through SPDIF. The used software and drivers should not be "aware" of the special nature of this audio signal. If you can play 44.1 kHz PCM stereo bit perfectly through SPDIF then you can play 44.1 kHz DTS .wav files or mounted disc images too. The only difference is that your external DTS receiver detects the signal and decodes it. If the files are ripped from DTS CDs you should not use the .dts extension.

If the files are 48000 kHz and not in a wav container (possibly extracted from DVD video) then you may need to find suitable DirectShow filters and settings for bit perfect pass through. This may not be easy.

A couple of years ago I wrapped some extracted 48 kHz DD audio tracks succesfully in the Matroska container file format for pass through playback, but I have not tried DTS. This thread has some info about that: http://yabb.jriver.com/interact/index.php?topic=26055.0.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Fonzo

  • Recent member
  • *
  • Posts: 10
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #4 on: May 10, 2007, 12:42:41 pm »

Note sure, these files are all below 800MB and the bitrate is 1.411 (or 44.1 kHz) in MC12. So, I guess they're from 5.1 DTS Music Discs. I have .wav with .cue file and a mounted DVD-RIP image (from Beethoven, can't help it) of which MC12 says they're both 44,1kHz, but refuses it to play in the M-Audio's DTS/DD pass-thru mode. Full DVD is played through the NVIDA decoder (or whatever suitable coded such as AC3filter) and SPDIF in pass-thru mode. I also have some some .dts single-track files, which only play if I rename the extension to .wav, otherwise MC12 says the M-Audio USB ASIO Interface does not support 6 output channels. Same problem when I switch to the ASIO4ALL driver.
Logged

ThoBar

  • Citizen of the Universe
  • *****
  • Posts: 992
  • Was confishy
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #5 on: May 10, 2007, 08:20:36 pm »

As an aside, it may be a nice feature for MC, that a "Pass Though Mode" be made available, especially if it could be associated to DTS, DD, or other formats that are supported by HT Receivers etc, but not to files that should not be passed through. I know this could be a bit dangerous (ie the volume level changes as a pass-through file follows a non pass-through file, with internal volume set lower), but may be worth thinking about?

I banged my head against this for a while too, and managed to get it to work, I'll have to dig around and see if the problems I had were the same as yours, and if so, provide some feedback for you, but I suspect mine were slightly different.
Logged

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #6 on: May 11, 2007, 05:11:23 am »

However, when playing .dts/.wav files, DTS-CD-images (on my hard disk as .cue with.wav files) or loaded in a virtual drive (.ngc and .img), the signal can only be played when selecting the "2-In/2-Out, 24-bit, 8000 – 48000 Hz" option in the M-Audio control panel. The output to the speakers is 5.1 and the receiver indicates DTS 3/2.1 output, BUT I noticed a quality difference between these two M-Audio control panel options mentioned above when playing DTS-DVD. Output though "pass-through" just sounds better.

I reread your original question. I think this quoted part means that the ".wav DTS" pass through already works correctly. It is supposed to deliver the apparently 2-channel PCM audio stream in fully unaltered form to the external decoder. If the DTS sign on your receiver shows up and you can hear multichannel audio then the decoder works. Otherwise you would hear only very unpleasant static noise.

With SPDIF pass through the perceived audio quality is depended on what your source material contains and how your receiver handles the signal. It is not possible to alter the quality on PC when an external decoder is used. This is the very nature of "pass through". You can only try to enhance the quality with the receiver's adjustments.

It is not possible to transmit decoded multichannel PCM stream through SPDIF. With usual home audio systems SPDIF is limited to 2-channel PCM or undecoded DD or DTS (or in some cases WMA Pro Multichannel) pass through.

AFAIK, if the files have .dts extension MC uses DirectShow filters for signal processing. I have not recently experimented with possible DirectShow filter combinations, but in any case if the source is decoded on PC you would need to use a soundcard that has 5.1 (or 7.1) analog outputs and use the analog connection or have installed a real-time software encoder that re-encodes the stream to DD or DTS before sending it to SPDIF. Possibly some DirectShow fiter combination/option can redirect the .dts files to SPDIF without decoding.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Fonzo

  • Recent member
  • *
  • Posts: 10
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #7 on: May 11, 2007, 09:27:38 am »

Ok, thanks. Your answer sounds logical.

I assumed the .wav decoding was indeed done in the external decoder, because the DTS sign indeed shows up on my Sony DTS-receiver. So somehow the undecoded signal _seems_ to arrive through SPDIF.

The thing that got me confusing was the fact that the DVD DTS 5.1 (Donald Fagen's Kamakiriad) sounds -just a little bit- better in "Dolby Digital/DTS pass-through 16-bit/48000Hz", rather than in "2-In/2-Out, 24-bit, 8000 - 48000 Hz" mode. So, I was wondering whether .wav DTS is really passed-thru undecoded to the external decoder.

Now that you mention "WMA Pro": I saw this somewhere in the options of Windows Media Player 11, where you can select to play WM Audio Professional over SPDIF (requires external audio decoder which should be compatible with WM Audio Pro and DirectX 9.0b or higher. I could not select this option (grayed-out), because the M-Audio is (apparantly) not supported. At this point I started to try alternative media players. Could this have something to do with it? When installing the official and latest M-Audio drivers downloaded from their website for the first time, I got a warning these were non WDM-certified drivers, which I of course ignored.

I contact M-Audio Technical Support and reffered to this topic. Maybe they have some suggestions.
Logged

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #8 on: May 11, 2007, 12:26:34 pm »

The thing that got me confusing was the fact that the DVD DTS 5.1 (Donald Fagen's Kamakiriad) sounds -just a little bit- better in "Dolby Digital/DTS pass-through 16-bit/48000Hz", rather than in "2-In/2-Out, 24-bit, 8000 - 48000 Hz" mode.

Possibly your decoder software detected the 2-in/2-out mode and sent signal that was decoded to matrixed surround or even plain 2-channel PCM stereo and your receiver used automatically matrix decoding or a simulated 5.1 surround mode, like DTS Neo:6.

Quote
Now that you mention "WMA Pro": I saw this somewhere in the options of Windows Media Player 11, where you can select to play WM Audio Professional over SPDIF (requires external audio decoder which should be compatible with WM Audio Pro and DirectX 9.0b or higher. I could not select this option (grayed-out), because the M-Audio is (apparantly) not supported. At this point I started to try alternative media players. Could this have something to do with it? When installing the official and latest M-Audio drivers downloaded from their website for the first time, I got a warning these were non WDM-certified drivers, which I of course ignored.
I contact M-Audio Technical Support and reffered to this topic. Maybe they have some suggestions.

MC supports WMA Pro Multichannel pass through. You can find the option here: Plugin Manager > Input > WMA > Configure...  I don't know if it works with a Transit. In addition your receiver must support WMA Pro decoding.
This thread has more info: http://yabb.jriver.com/interact/index.php?topic=30804.0
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71458
  • Where did I put my teeth?
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #9 on: May 11, 2007, 12:47:39 pm »

I've added this thread to the FAQ.  Thanks, Alex.  As usual.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71458
  • Where did I put my teeth?
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #10 on: December 08, 2010, 07:18:51 am »

You might want to try JRiver Media Center.  This is the forum for it.

www.jriver.com

See this thread for setup of audio:
http://wiki.jriver.com/index.php/Audio_Output_Modes

I think you're on XP.
Logged

HTPC4ME

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 2759
  • LIFE IS A RADIO... CRANK IT UP TO 11!
Re: Cannot play DTS-CD in pass-through mode with M-Audio Transit USB
« Reply #11 on: February 01, 2013, 04:33:07 pm »

Hi guys i just found 3 DTS discs from when i worked at audio king, and i'd love to get this on the htpc.. what is the suggested way of ripping these?
thanks
Logged
Pages: [1]   Go Up