INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Audio dropouts  (Read 6125 times)

skifastbadly

  • Junior Woodchuck
  • **
  • Posts: 98
Audio dropouts
« on: December 31, 2014, 09:33:13 pm »

Hi folks,

I've just recently moved to MC from Windows Media Player and I'm in the middle of an immense learning curve.  I have a bunch of questions but the current pressing one is Where are all the dropouts coming from?

I never experienced dropouts with WMP but it's a fairly constant annoyance for me in my current configuration which is:

HP Desktop with S/PDIF out put to my Adcom DC 700 DAC
Windows 7

It seems like on just about every song, there's a dropout and it's like Chinese water torture waiting for the next one.

I've tried both "Default Audio Device Direct Sound" as well as "Realtek Digital Output with WASAPI" and there doesn't seem to be a difference.

I've downloaded the DPC latency checker, and it showed some issues but after I uploaded and installed the latest driver version for the card, the latency checker indicates all should be well.

I've tried "play from memory", I've increased the buffer and I've increased the playback latency to max (500ms) to no avail.

The files, all FLAC, are on an internal SATA hard disc.

I'm running out of ideas and hope someone has a hint for me.

I do get a lot of "Disc Spinning Up" messages which I've NEVER seen before, which I infer could be related....


Is there something obvious that I'm missing?

 Thanks and happy 2015
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41976
  • Shoes gone again!
Re: Dropout Blues
« Reply #1 on: December 31, 2014, 09:46:46 pm »

That's a weird one.

Increase buffering in Options > Audio > Device settings.

Increase pre-buffering in Options > Audio > Prebuffering.

Does that help?
Logged
Matt Ashland, JRiver Media Center

skifastbadly

  • Junior Woodchuck
  • **
  • Posts: 98
Re: Dropout Blues
« Reply #2 on: December 31, 2014, 11:01:10 pm »

That's a weird one.

Increase buffering in Options > Audio > Device settings.

Increase pre-buffering in Options > Audio > Prebuffering.

Does that help?

Hmm not really, I maxed out both parameters.   I do have HDMI for the monitor, might there be a clash there?
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71470
  • Where did I put my teeth?
Re: Dropout Blues
« Reply #3 on: January 01, 2015, 02:09:36 am »

Try the thread called "Weird and Wonderful".  There is a link in my signature.  I just added a post yesterday on a problem that was caused by an Intel tool.  Antivirus programs can also cause such problems.
Logged

CountryBumkin

  • Citizen of the Universe
  • *****
  • Posts: 3352
Re: Dropout Blues
« Reply #4 on: January 01, 2015, 06:52:31 am »

Can you try playing using "Windows" sound device (e.g. Realtek to desktop speakers) for testing purposes and remove the DAC from the equation? If it has no drop out then I would focus the troubleshooting on the DAC or its connection. If it still drops out, then you would focus on the computer/JRiver settings. Regarding "disk spin up" messages, perhaps check in Windows>Power Options >Advanced settings and see what the disk sleep time is set to.
IMO
Logged

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: Dropout Blues
« Reply #5 on: January 01, 2015, 08:43:04 am »

Hi

A friend of mine had a similiar issue ... and it was DAC related. Could you do the test first, something like CountryBumpkin mentioned ? Maybe you were using Direct sound before (to avoid imho) and WMA just let you get away with it ....

Googling your DAC it seems like it has some age to it. (maybe before WASAPI was widely used?) -- on my friends system, I switched from WASAPI to ASIO and it worked much better. As his DAC was old and did not provide drivers I used the JRiver ASIO; if you are using another internal soundcard other than the motherboard, might want to take that "out of the equation" too or use the ASIO driver if it was provided with the board.  For testing purposes, if you are using the WDM driver from JRiver you might want to disable that and use the recommended latency settings first ... especially sa these have not had any real effect so far.

Although anti-virus can be a cause of a lot of problems, what I do is exclude your listening files (either by drive location and/or file type like *.flac). Depending on your system and drive configurations, your AV could be analyzing files in real time which could cause disk spinups too. As CBumpkin already brought up, drives, especially Green drives which park the heads, could be linked to this "lag"  - even if it is not the problem, who needs the noise if the drives are local?

Out of curiosity, do you have the memory playback option set in MC?

 
Logged

AndyU

  • Galactic Citizen
  • ****
  • Posts: 363
Re: Dropout Blues
« Reply #6 on: January 01, 2015, 08:49:41 am »

It might be worth checking your processor scheduling.

Control Panel > System and Security > Advanced system settings > Advanced > Performance Settings > Advanced


.. you should see:

Processor Scheduling
Choose how to allocate processor resources

Adjust for best performance of:

you have choice of Programs or Background Services


Try whichever one isn't selected and reboot.

Logged

skifastbadly

  • Junior Woodchuck
  • **
  • Posts: 98
Re: Dropout Blues
« Reply #7 on: January 01, 2015, 04:29:39 pm »

Well I am part way there.  Since my DAC supports HDCD I long ago set the sound card output to 2 channel 24 bit 44100 HZ.  Apparently this creates a problem with the WASAPI output.  I put everything back to initial values and set the output path to default audio device and not a single skip so far, half way through Astral Weeks.  Apparently I can have direct hardware or HDCD  but not both.
Logged

skifastbadly

  • Junior Woodchuck
  • **
  • Posts: 98
Re: Sound dropouts
« Reply #8 on: January 01, 2015, 09:30:31 pm »

First things first, I think I may have wasted a bunch of other people's time on this and for that I apologize.  I believe I have it all sorted, and I'm going to post the results in hopes that it saves someone else some time.

One of the unique aspects of my configuration is that I am using my living room TV as both a TV and as a monitor.  I have HDMI from both the computer and the Comcast box.  I take the audio from the computer SPDIF digital into the earlier mentioned Adcom DC 700, a DAC I specifically use because of its support of HDCD.  Up until the installation of JRiver,  all sound from the computer (including Youtube, Netflix, etc) came through the DAC and hence the amp and stereo speakers, and all sound from the Comcast came through the second HDMI through the TV speakers.  Which worked fine because I have a home theater in another room which if I want to watch movies, etc., is where I go.

Once I set up JRiver to try and use the WASAPI output, things started getting weird.  One thing I noticed once I hooked it up and specified that the WASAPI should be exclusively controlled by JRiver, suddenly HDMI started being used for stuff not being played through JRiver, which is to say the above media streams.  Wow, somehow by accident I got that problem resolved.  But the dropouts were driving me nuts, and it seemed to be getting worse.  Finally, at the end of my rope, I decided as a last resort to read the instructions on setup again, and specifically the DAC setup section.  And that's where I found a very important deviation from what I had done. I quote:
Media Center Windows 19

    Audio Device

        If your device has it's own driver installed, select it from the list. Otherwise the best option will normally be "High Definition Audio Device [WASAPI]". Find more information at Audio Output Modes.

    Device settings

        Open device for exclusive access: Checked
        Disable event style: Unchecked (may need to enable this on some older devices if you have problems)
        Maximize device volume during playback: Unchecked

And that's what I had screwed up, I had checked the Maximize device volume because that's what I had to do before to ensure that I was getting the full digital signal to the DAC.  Once I unchecked that, everything started working as designed and imagined, and through four hours of play I've not had a single drop.

RTFM, as they say.

Anyway, I think I'm all sorted.  I do note that in this configuration the playback indicates it's going out 32 bit, not 24, but hey, it's working.


I hope this helps, and I greatly appreciate the effort put in by people responding to my posts above and feel free to call me an idiot.  My wife does.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71470
  • Where did I put my teeth?
Re: Audio dropouts
« Reply #9 on: January 02, 2015, 02:01:58 am »

You're a good person to post the solution.   Thanks.
Logged
Pages: [1]   Go Up