INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: MC 20 Hanging When Exiting Display View to Theater View  (Read 4317 times)

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
MC 20 Hanging When Exiting Display View to Theater View
« on: November 03, 2014, 01:45:12 am »

Hi

This issue has been raised before and logs etc provided but still I am getting a problem.

I am getting an issue with MC hanging in Theatre View. It is a reproducible set of conditions and happens every time I hit that set of conditions.

I am using the JRiver USB (HP) Remote Control handset to control Theatre View

To repro it

Go Into Theatre View
From Rolling Menus Goto Video > TV Series - I get a set of thumbnails of the Series
Select a series - I get a set of thumbnails of Seasons
Select a season - I get a set of thumbnails of Episodes
Select an episode - I get a detailed screen of that episode with a "Watch" button
Click watch and the episode starts
Press the "Go Back" button on the Remote, I go back to the episode detail screen but all buttons are inoperable (hanging)

If I press the stop button while a video is running then I return to the Episode Detail screen and all is well, I can restart the episode or any other episode.

I have seen it on all sorts of file types , mostly my files are avi, mp4 or mkv

The only way out is to Ctr Alt Delete to get up Task Manager normally this "breaks the hang" and MC returns to standard view without having to restart it. Occasionally I have to End Task on MC and restart MC
 
Setup

The PC is Lenovo i3 (quad core) Lap top with 4 G RAM , Graphics are Intel on board no separate video card. OS is Win 8.1 (up to date on all patches) and only runs MC. (There are other programs installed like CUE Tools and BU software but in essence it is a dedicated PC, no obscure software. The PC was loaded from "new" so there should be no stray libraries etc)

The MC is being used in Server Mode to allow the use of JRemote but feeds the DAC and TV. It auto starts into Std View on Startup.

I have followed Glynor's crib sheet on set up and anti virus set up .. My data drives are excluded from the normal AV checks. AV is Win 8 Windows Defender

The Data Drives are 2 x External USB 3 plugged into the PC USB3 ports directly , one for Audio , one for Video. The library is around 120k files roughly half audio and half video. Cover Art and the main Library files are stored on the C drive.

I have eliminated external drives , I can reproduce the same conditions with files located on the C Drive and no external drives connected.

Everyday operation is using JRemote for Audio and the JRiver remote control for video and Theatre View.

While not a show stopper its extremely irritating , my idea is to have a mouse and keyboard for maintenance not everyday operation.

Matt did have a look at it and concluded from the logs


That means it hangs in:
m_pD3DGetAdapterDisplayMode
or
s_GetAdapterFromWindow



Does anyone else see this , can someone try this set of conditions to tell if its my PC or the software or what ??

Cheers

Mike
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: MC 20 Hanging
« Reply #1 on: November 03, 2014, 08:07:04 am »

I think there is something going on with this.

There have been a few other posts I've helped with that seem similar, including this one:
http://yabb.jriver.com/interact/index.php?topic=92756.0

It does not happen to everyone, though, for sure.  So it would be useful if we could somehow track down what the systems that exhibit the problem have in common.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging
« Reply #2 on: November 03, 2014, 08:53:27 am »

Hi Glynor

That link makes interesting reading sounds like nickbuol is seeing the same symptoms , presumably with different hardware configuration. My PC is less than 6 months old so I assume drivers are not too out of date. Also it has never had any "rubbish" installed and uninstalled, I know the odd stray DLL can cause odd behaviour.

The only software installed is

JRiver
Cue Tools
TheRenamer
SyncBack

Not sure if any have a reputation for interference?

I tried eliminating the external drives , I copied some video to the C drive and created a new clean library with 24 files in it , all on C drive. Just the same response.

I also noted that the Music external drive was showing massive activity , so I disable Run Auto Import in the background. Alas still no change so I put it back.

I have the J River (HP) remote with a green Windows Media Player button , I'll give that a whirl.

Also in that post is the fact that Ctr Alt Del "snaps" it out of the hang without starting Task Manager, I see that too . That behaviour is sporadic though, some times it returns to Std View some times fired up Task Manager and then you can kill MC from there.

BTW when you kill the MC App should the service stop as well , it doesn't ?

Also it seems that the maybe the audio is still running , that implies the video must still be being processed but the video output isn't showing. Seems like that could be a hint maybe.

I have also noted on the Episode / movie detail screen the "Preview Image" is blank . I have seen in the past that that preview is a snapshot from the current position in the movie (am I right?)

I'll keep posting my attempts to narrow it down.


Cheers
Mike
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: MC 20 Hanging
« Reply #3 on: November 03, 2014, 09:07:11 am »

I strongly suspect the issue is going to be found to be hardware-specific.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #4 on: November 05, 2014, 04:20:06 am »

Hi

Are there any suggestions how I eliminate stuff to resolve this ?

Surely going back to a previous screen is a common activity in Theatre View , I can't imagine I am the only person seeing this phenomenon ??

Mike
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42064
  • Shoes gone again!
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #5 on: November 05, 2014, 10:05:42 am »

I just can't reproduce this.  I start playing, hit Backspace and am shown Theater View right where I left off.  The cursor moves as expected.
Logged
Matt Ashland, JRiver Media Center

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #6 on: November 05, 2014, 10:57:59 am »

Hi Matt

Does Backspace on a keyboard do the same as the Back Key on the HP remote ?

I am using the HP remote bought through J River, with no customisation of keys or "training" and it's this action that causes the problem. I run a video for a minute or so and do a "Go Back" on the remote and it hangs . If I hit stop on the remote it stops and allows normal resumption. In both instances it reverts to the episode selection screen not the episode detail screen so it doesn't do a strictly one step back which would be the episode detail screen.

I suppose one rather labour some test is to completely substitute the PC with my main laptop and see if I can replicate it with completely different hardware but that does seem a little extreme and is not really a tenable option for the long term.

I haven't tried reprogramming the remote , is there an alternative command I can attach to the Back Key that would help ?

While not a showstopper , my natural action is to use the back key and the centre key to navigate back and forth , I should obviously use the stop key.

Cheers

Mike
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42064
  • Shoes gone again!
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #7 on: November 05, 2014, 11:21:38 am »

What if you hit the green button instead of back?
Logged
Matt Ashland, JRiver Media Center

gvanbrunt

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1232
  • MC Nerd
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #8 on: November 05, 2014, 07:30:07 pm »

Hmm. I saw something similar today, but in MC 19. Not sure what my wife did but it was sitting at the "resume/start from beginning" dialog in Theater View. Remote would not work no matter what I tried. I tried setting focus with the mouse etc. to no avail. I used the keyboard to hit back and all was well. The remote started working.

Only thing I can think of is somehow the remote hardware is "sending to a different focus" than the keyboard. Don't know if that make sense, but any ideas on how that could happen? IE the MC does not have focus so the remote does not work but the keyboard is more "universal" and sending to "all programs".

My low level Message Loops days are long ago, so I'm not sure even how to express what I'm thinking here, but maybe it strikes a chord.

One thing in my case is there is an intermediary program involved to some degree. There is iMon that actually receives the remote signals and sends them as keystrokes.
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #9 on: November 06, 2014, 03:31:51 am »

Hitting the green button (I assume you mean the "windows" button) has the same effect. I have Windows Media Centre startup disabled in Options.

Using <Backspace> on the keyboard doesn't help either

When I do a <Back> should playback stop ? It isn't eventually after Ctr ALt Del , I occasionally get back to the full display screen still showing the video.

Only hitting Stop actually reverts n an unhung state.

The other odd thing is that on the "screen that starts the individual episode", The preview box on the RHS shows a sample image from the episode, once it has hung that box shows NO image. I Also recall that it used to show a current image from the episode , do I remember correctly.

I will try to swap out the two lap tops today and let you know.

I can't specifically remember when this started happening as I only recently started using MC for video to eliminate my Mede8er (and simplify things), but I am pretty sure it was before the upgrade to V 20 , so gvanbrunt's experience with V 19 may well be related.

I am beginning to come around to glynor's thought that it may be individual hardware , BUT why ?


Cheers

Mike
Logged

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #10 on: November 06, 2014, 04:40:52 am »

I have exactly the same issues, but it does not hang all of the time. And the only way to get out of it is like you do, task manager brings things back Mike.

Another hang I get is if I start a video from standard view (it opens in Display view) then I hit on the remote to go into theatre view. This I can reproduce everytime

Also I get can theater view to hang if I rapidly scrowl through my audio albums. Jim told me yesterday that it is probably due to a video driver problem - I'm using onboard HD4000 graphics from an Intel i5 sandy bridge. Apparently this series has all kinds of freeze problems. I'm going to see if there is an update from Intel today.

Do you have a separate graphics card Mike?

Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #11 on: November 06, 2014, 05:20:51 am »

Hi

No separate graphics card , it is i3 and HD 4000 graphics, my other laptop has a separate card , I am going to try that today if I can

Mike
Logged

gvanbrunt

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1232
  • MC Nerd
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #12 on: November 06, 2014, 09:42:26 am »

One thing to point out. It was mentioned that pressing stop worked, while the back and arrow keys didn't work. The stop butting is a media key as opposed to a regular keystroke. I'm wondering if they get treated specially by the OS or MC? I've seen similar issues as well when only media keys work on the remote but others don't. Can't remember the exact circumstances though.
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #13 on: November 06, 2014, 10:13:36 pm »

I think it would be extremely useful to see if the people getting this hang are seeing the same thing in their logs as I noted in the other thread (which seems, otherwise, identical to this one):
http://yabb.jriver.com/interact/index.php?topic=92756.msg639007#msg639007

FWIW, though, if I remember right, he had Nvidia hardware.

Intel GPU drivers are a huge bag of fail though.  It might be worth, especially with a HD 4000 GPU, rolling back to an older version (perhaps one from soon-ish after the 4000 came out) to see if this is some kind of recent driver regression.

It would make total sense from the described behavior that it is a GPU driver crashing or hanging when entering/exiting Direct3D mode.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #14 on: November 07, 2014, 03:03:44 am »

I think hardware may be a red herring ??

I have completely changed the PC and the response is the same.

My main lap top is i7 2670 QM 8G Ram win 8.1 Pro with a GeForce 520MX video card

My Media PC is i3 2384 M 2.3 G , 4G Ram , Win 8.1 Single Language Intel HD 3000 Graphics

Windows is fully patched on both

I copied a series of 20 episodes to my C drive and created a new library with just these files in there. (also looks like USB external drives maybe a red herring too, no drives attached).

I ran a single episode , and tried 4 ways of "going back" ,

Green Button on the remote (I have unchecked the disable check box in Options>Startup)
Backspace on keyboard
Go Back Key on the remote
Stop Key on the remote

In the first three the system hung just as on the other PC , the stop key worked as on the other PC.

The only way out is to Ctr Alt Delete , incidentally the Display View is still running at this stage and I killed it using the Player Controls at the top.

All the symptoms I have mentioned above were identical. The preview image was missing as before.

The Lap Top is my main Dev PC and is loaded with all sorts Visual Studio etc and even running SQL Server in the background, the media PC is simply running MC with a couple of other programs dormant.

Two very different animals BUT the same response .

I am not sure what more I can do.

I understood that the green button toggles between Theatre View and Display View , is that correct.

Where Next ?

Cheers

Mike


Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42064
  • Shoes gone again!
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #15 on: November 07, 2014, 08:37:56 am »

I'm totally puzzled by your hang.  I just can't reproduce it.

I wonder if the graphics driver of the Intel could play a role?  Could you update to the latest if you haven't?
Logged
Matt Ashland, JRiver Media Center

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #16 on: November 07, 2014, 08:49:57 am »

I already did when I discussed this with Glynor a few weeks back , even so an old driver wouldn't explain why it happens on both PC's , the second one I tried had a separate video card as I explained.

Could it be something in the HP Remote set up maybe.

I assume your PC is somewhat higher spec'ed than my lowly I3 Media Lap Top I described above. I often found when I was developing for a living that the developers big butch PC often didn't replicate issues found with "lowly user's PC's"

Does the fact that the Display Mode not stop give any hints or the lack of the Preview Image , both these don't seem quite right.

I can work around it but only constantly having a keyboard and mouse out in the living room , which sort of defeats the object of Theatre View and a Remote

Cheers

Mike
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #17 on: November 07, 2014, 09:02:51 am »

I believe the i7 machine would still have an Intel graphics driver installed.

Anything else in common?  Especially video related.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #18 on: November 07, 2014, 09:13:17 am »

One thing in my case is there is an intermediary program involved to some degree. There is iMon that actually receives the remote signals and sends them as keystrokes.
This is an example of the type of thing that can cause problems.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #19 on: November 07, 2014, 09:15:07 am »

Could it be something in the HP Remote set up maybe.
What do you mean by this?  Did you customize it?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42064
  • Shoes gone again!
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #20 on: November 07, 2014, 09:17:22 am »

I can work around it but only constantly having a keyboard and mouse out in the living room , which sort of defeats the object of Theatre View and a Remote

So the hangs don't happen if you use the keyboard, but do if you use the MCE remote?  That's really strange because all an MCE remote does is act like a keyboard.
Logged
Matt Ashland, JRiver Media Center

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #21 on: November 07, 2014, 09:20:03 am »

Hi

The remote is "straight from the box" no training , adjustments or anything.

The remote I assume is issuing a <Backspace> keystroke from what I have read above. Doing that straight from the keyboard has the same hang effect.

Mike
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #22 on: November 07, 2014, 09:27:20 am »

@Jim

The i7 Machine has HD3000 graphics on the mother board , but I assume that a dedicated video card (GeForce 520MX) will bypass the on board graphics (not an area of specialism for me).

The two machines are very different, the i7 machine is my Dev machine with all sorts of software and service running that could interfere. For example it has SQL Server running in the background.

The i3 Machine is my Media PC and is a clean win 8.1 install running only MC. It does have other programs installed but nothing running and not really "services" based software. It has CUE Tools, DVDfab and BU software. Not even Office or anything

This i3 is idling , its running between 4 and 5 % CPU , and minimal RAM usage. It's hard to think its resource constrained.

Also the test with the I7 didn't use any external USB drives which were also being considered as an issue at one stage.
Mike
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42064
  • Shoes gone again!
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #23 on: November 07, 2014, 09:34:17 am »

I just tested the 3 development machines we have here, and they all leave a playing video and resume Theater View no problem.  This was using an MCE remote.

I'm riddled.
Logged
Matt Ashland, JRiver Media Center

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #24 on: November 07, 2014, 10:56:05 am »

Hi

I have even had my wife go through the hang steps to make sure I am not cracking up  ;D

I have repositioned the remote sensor to a spot directly below the TV (I suppose you always point at the TV rather than the sensor?) , I was wondering if where it was it didn't get every key press , although its very unlikely , it still seems that Stop works and Back leaves the video running but a hung screen.

I have just seen an error "error drawing direct3d , device missing" or the like , does this help.

Is it possible I am pressing key sequences too quickly ?

Mike
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #25 on: November 07, 2014, 10:58:33 am »

PS

I have set the startup to Theatre View not Std View if that makes any difference.

It would also seem the on off key pressed (puts PC to sleep) and then again to wake it clears the hang ??

Mike
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #26 on: November 07, 2014, 11:13:51 am »

It would also seem the on off key pressed (puts PC to sleep) and then again to wake it clears the hang ??
When you do that, a lot of hardware level processes might also be re-initialized.

Turning a monitor off and back on might also do the same.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #27 on: November 07, 2014, 12:47:40 pm »

We started a thread on a similar problem here:

http://yabb.jriver.com/interact/index.php?topic=93174.0

Yours is different so please use this thread.
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #28 on: November 11, 2014, 12:12:29 am »

Hi

I am stuck , nothing has changed , any suggestions where I go next ?

I have done some sorting out ...

Created a User Account for "media player" that starts without password on startup
Set up MC to start on startup
MC starts up  in Theatre View
So now I hit the on button and Theatre View appears.
Trying to Close Down the PC when leaving Theatre View after a session (even though this means grovelling under cabinets to restart the PC.

At least now the only action should be startup and shutdown. I don't know if it will help....


Mike
Logged

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #29 on: November 11, 2014, 05:36:30 am »

Mike this might be totally off the wall, but I was going to post a log of mine as I can make Theater View hang or crash pretty easily as I mentioned above -- ctrl+alt+del would bring it out of a hang, but not a crash of course.

I neglected to look at one thing .. my browser setting. Now this has not fixed every hang that happens, but it seems to correct most of them that I'm not trying to provoke at least.

Browser was set to Internet explorer and I just changed it to Chromium. (Options, Tree and View, browser engine)

Now this may not help you at all, maybe you are already on Chromium. Just thought I'd throw it out there.

Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #30 on: November 11, 2014, 09:26:32 am »

"What a mistaka to maka"  ?

Changed the setting , I assumed (wrongly ?) that I needed Google Chrome installed so I installed it , rebooted the PC and Blackness.

It started up as it should straight into Theatre View and then a complete black/blank screen.

I stopped it (ctr Alt Del) , even the mouse didn't work !! and read about Chromium , So I uninstalled Chrome , then I uninstalled MC deleting Registry Settings and reinstalled MC, rebooted for good measure and again a black/blank screen.

This is on a specific Media Centre user , so I have had to revert to my login as administrator just to get any sort of activity

WTH went wrong , I certainly don't know.

I am still running with IE as the default browser.

I assume Theatre View is an HTML generated view to be browser specific

I will completely delete the MC user and start again tomorrow.

Mike
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #31 on: November 11, 2014, 09:30:06 am »

Changed the setting , I assumed (wrongly ?) that I needed Google Chrome installed so I installed it

Yes.  That was incorrect.  Chromium is not the same thing as Chrome.  MC includes the engine required, but it is disabled by default on Windows.

Theater View is not HTML generated, and doesn't use the web components at all.  Some elements of Standard View are web elements, though, such as:

* Playlist headers
* The Start page
* Other informational displays

The only way that the web engine could impact this is if the bug happens when exiting "normal" mode with a web-view showing and enters Direct3D (the problem is the transition, and is impacted by state before and after).  Possible, but I'd bet it is more likely to be the GPU driver flaking out in Direct3D.

It isn't clear at all what you mean by all of the Administrator stuff at all.  Please explain further.  This behavior should have nothing to do with any of the Media Center Users.  If you are talking about a user account on the system (in Windows) then that's something else.  But if this has any impact at all, then it sounds like you're having issues with the computer generally.

However, I'll say again, the "blackness" you've described is almost certainly a hardware fault.  If your computer is ever crashing so badly (when entering Direct3D that it goes black like that and you lose all mouse control and you have to do a system interrupt (control-alt-delete) to "unstick" it, it is almost certain that is a driver or hardware issue.  Media Center can only call the Direct3D APIs, and the driver is supposed to do what it is supposed to do.  It is possible that it is a bug in MC, but it is much more likely that it is a bug in the driver (or failing hardware, though with the multiple reports, this is less likely) that MC has not worked around.  Intel's GPU drivers have been notoriously bad and difficult to deal with in 3D for a LONG, LONG, LONG time.

If it was me, and I had the time to put into testing, I'd do the following:

1. Normalize as much as is possible about your installation.  Run on a well-used, well-defined user account on the machine.  Run MC with a small Library (just a handful of well-known test files) with as close to default settings as is possible.
2. Test.
3. Remove your GPU driver entirely.
4. Reboot.
5. Test.
6. Install an old version of the Intel GPU driver (close to the time when your hardware was first supported).
7. Reboot.
8. Test.
9. Repeat 6-8 for successive versions of the Intel GPU driver and see if the behavior changes.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #32 on: November 11, 2014, 09:56:23 am »


@Mike sorry about that confusion , ouch  :-[

maybe this would be clearer .. doesn't matter what other browsers you have installed (I have 3 on my htpc)

don't know why it helped me either Glynor (here's a log of a crash with IE as the engine already posted in Matts "hang" thread)



Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #33 on: November 11, 2014, 10:00:12 am »

Oh, I know the browser engine choice can be troublesome in some cases.

I just don't think it is likely it is impacting this exact thing with Theater View.  There could be multiple, otherwise unrelated, issues happening.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #34 on: November 11, 2014, 10:35:37 am »

Just to clarify the user thing ...

Previous to this week my PC ran in administrator user account so needed a password at each startup. My PC ( a laptop) sits on the floor under a hi fi cabinet , and I am an "ailing old man"  ;D, so to grovel to enter passwords etc is a pain , or to get a keyboard out is a pain and something I am trying to eliminate .

So what I did was set up a new user called "Media Centre" which as a std user I can have with no password so when I boot it starts windows and MC directly into Theatre View with no intervention. Hence I have to simply switch on the PC .

I am in Johannesburg ,the thunderstorm capital of the world . Frying motherboards etc. is not uncommon in the severe thunderstorms we get almost daily, so all electronics get turned off and unplugged overnight (or as needed in the day , we use a big UPS to keep watching etc) in the summer , so a restart is a daily event. In winter its fine and I leave stuff on.

It was in this user account I made the change , so far I have not managed to recover that user, as it starts directly into MC or in this case doesn't so I can't even turn off any options to test.

The administrator user has IE set as the browser and starts up in std view and all seems well. It's the other account that is playing up . Maybe I just delete it start again from clean.

I'll follow your plan tomorrow and see what I can see. I have actually seen an error message before now saying something to do with Direct3D , so you may be the right track.

Do you have any idea how I can take out option settings without having MC Running , I assume  Registry setting but I am hesitant to play ...

Mike

Previous to this I had one account as Administrator which obviously requires a password and a grovel ...

Cheers

Mike
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #35 on: November 11, 2014, 10:46:58 am »

@ Arindelle

No problem , we live and learn and I lost nothing other than patience and a few chapters of my current book !!

I obviously got Chrome and Chromium confused , I hd not heard of Chromium until I read about it later.

Where you show is exactly where I made the change , I wonder if installing Chrome tipped the balance somehow. This PC is a newish one and deliberately clean , it only has MC and a couple of odd programs installed (CUE Tools and DVDFab and SyncBack for BU) and I have deliberately avoided putting anything else on. My main Dev PC is a mess of all sorts of programs so I aimed to do the opposite.

I can't really see Chrome causing this

I'll post again tomorrow with my successes or failures

Cheers

Mike
Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #36 on: November 12, 2014, 03:58:36 am »

I had set up Windows User Account just for MC

I changed the default browser to Chromium as suggested , MC was set up to start with windows and start in Theatre View. Every time I started MC it hung with absolute Blank / Black screen. CTRl ALt Del got me out (MC not responding) but I couldn't get back into MC to change anything in Options as every restart tried to go into Theatre View (is there a way to bypass the startup view like holding a key down or something, if not is that not a good idea? )

The only way out finally was to delete the user account and recreate it . With a clean install of MC set up to do nothing at Windows start and to start in Std View . I left Default Brower as IE and all was well and worked normally.

From that base I changed just the Browser setting to Chromium, and Whammo the same effect a Blank screen with MC not responding.

I couldn't get back into MC to change the option back to IE so I had to delete and recreate a clean user account AGAIN .

I have now restored library etc and set it up with IE as the browser and all is well again so ...

It looks like there is a serious mismatch between my PC and Chromium, I don't know enough about it to comment.

I am not sure I will change anything else it just seems to create more work setting it straight.

I guess I will just have to live with the quirks of Theatre View on my setup.

Maybe I just listen and watch it .....

Cheers

Mike
Logged

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #37 on: November 12, 2014, 05:10:17 am »

@Mike

it would be helpful I think if you could post some logs and send them to Matt. Do you know how to ? (Top Menu=>Help=>Logging) I'd reset the logging first otherwise it might be huge.

There s a thread for this -- http://yabb.jriver.com/interact/index.php?topic=93174.0

Jim said to keep your topic here, but posting the log there won't do any harm and Matt or someone will download it 

Logged

MikeO

  • Citizen of the Universe
  • *****
  • Posts: 792
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #38 on: November 12, 2014, 05:40:27 am »

Hi Arindelle,

Matt has already had logs from the initial hang problem and was at  a loss to suggest a cause .

I have literally spent hours getting things straight from the change with Chromium, to reverse it and do logs would screw up all that work.

I am already frustrated enough without adding to it. I suppose I could set up another Win User Account to repro it if Matt thinks he could get any benefit from it.

Mike
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71755
  • Where did I put my teeth?
Re: MC 20 Hanging When Exiting Display View to Theater View
« Reply #39 on: November 12, 2014, 06:09:00 am »

Odd problems like this are often caused by "security" software.  I'm not saying this one is, only that it's a consideration.

Also I get can theater view to hang if I rapidly scrowl through my audio albums. Jim told me yesterday that it is probably due to a video driver problem - I'm using onboard HD4000 graphics from an Intel i5 sandy bridge. Apparently this series has all kinds of freeze problems. I'm going to see if there is an update from Intel today.
Video driver is another possibility.  Sometimes updating to the latest will solve a problem like this, but sometimes the latest driver is the one that has the problem.

MikeO and Arindelle are both using Intel on-board video.
Logged
Pages: [1]   Go Up