INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 3 4 [5] 6 7 8 9   Go Down

Author Topic: NEW: Blu-ray Menu Support (Beta)  (Read 21387 times)

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #200 on: March 31, 2018, 05:43:16 am »

Win64 on the HTPC.  64-Bit java downloaded by MC (and only once, in my testing I deleted the Java Folder to re-download).  Only AV is MS Windows itself.  Copying msvcr100.dll to the server folder did not help.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #201 on: March 31, 2018, 06:00:05 am »

Can you confirm that msvcr100.dll does not actually exist in C:\Windows\System32? Don't want to be chasing my tail here.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #202 on: March 31, 2018, 06:08:27 am »

No msvcr100.dll but there is a msvcr100_clr0400.dll in C:\Windows\System32
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #203 on: March 31, 2018, 06:10:22 am »

On the PC that does work there is a C:\Windows\System32\msvcr100.dll dated 11/06/2011
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #204 on: March 31, 2018, 06:13:39 am »

Bingo!  If I copy msvcr100.dll to the C:\Windows\System32 folder it works
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #205 on: March 31, 2018, 06:50:55 am »

Want to avoid having to do that, don't we.

So hopefully the last thing
- Get rid of the copy in System32 again, as well as the one you possibly copied around in the java folder (or just delete it and let MC download a fresh java)
- Get this libbluray replacement (64-bit only): https://files.1f0.de/tmp/jvm-crt/x64/libbluray-2.dll and put it into the plugin folder

See if stuff works? Since its like 11pm for you, I'll just go enjoy my saturday now and come back later. If it works for you as well, I'll roll a new libbluray package next week.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #206 on: March 31, 2018, 03:21:43 pm »

All good.  Tested on the two PCs.  Have fun, I'm off to Cairns for the week (Hope the cyclone has left something behind to enjoy)!
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #207 on: April 06, 2018, 02:07:04 pm »

Main issues were with these titles:
- American Beauty: Freeze at end of opening 10 sec splash screen (MC Hang)
- 71: Freeze on start
- The Adventures of Priscilla, Queen of the Desert: Freeze on start
- 8 Mile: Freeze post menu (and warnings)

I managed to get ahold of those listed above, and only one shows any issues (The Adventures of Priscilla, it shows a message about updating my Blu-ray player and then never progresses further without any indication in the log)
I don't know if EU releases are just generally "better" or what, but all of the others just play fine. Note that I do always test straight from the optical disc.

Or perhaps there is a region check on some of your discs, which is failing? libbluray has a region setting, but so far it didn't seem to impact anything, so I didn't expose it.
You would think the disc would yell at you like DVDs used to, instead of silently failing.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #208 on: April 06, 2018, 05:04:16 pm »

Thanks for the cross test.  I'll also recheck when I'm back.  Is there anything in the logs to look for or any other way to work out what is up with these discs?
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #209 on: April 08, 2018, 12:59:26 am »

Rechecked those 4, no change for me - log attached.

Edit - Checked 8 Mile and '71 off the disc as well to see if it is different (and it is not, same issues).  To me they both look like Region B EU releases. 

Edit 2 - I know that '71 was working (on at least my main PC) when we first did testing as I attached logs for missing Menu Items under MadVR.  I also checked C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache and there are no files to delete.  No idea why it is being difficult for me but I'm betting it is something to do with my setup.

Edit 3 - I can see files being written to C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache but they are removed when pressing STOP.

Edit 4 - When the freese happens you can not use the Theaterview OSD (up arrow etc does nothing), it just remains a black screen... but the right click menu works (eg you can start title playback).

Edit 5 - I don't know if this helps but here is a Zip of the libbluray-bdj-cache for '71
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #210 on: April 08, 2018, 01:02:56 am »

Did the 21 Jump Street Dump show anything?

Also - thanks for the other changes
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #211 on: April 08, 2018, 02:57:14 am »

I've found something.  I'll need to test more but if there are values in "Playback Info" like "(1:2)(7:Streams)(6:0,4,23)(9:Subtitles)(0:)" then clearing them seems to make more discs play without issues.  '71 and 8 Mile now work.  I "think" also have a bookmark confuses some discs.  I'll clear both values and retest a bunch.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #212 on: April 08, 2018, 02:58:40 am »

Bookmarks should be ignored on Menu playback already, maybe I need to make it ignore the others as well? Due to all the different streams between logos, trailers, menu and the main movie, its hard/impossible to apply such things anyway.
Although I'm slightly confused how that broke playback, considering it doesn't even support controlling streams from the outside. Well something to check on next week.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #213 on: April 08, 2018, 04:29:59 am »

Yeah no rush.  Just back at home and did some testing before I have to go away again for work.  Just did a quick test on 100 Discs (all rips).  I cleared all the Book Marks and Playback Info.
- About 1/3rd have no "Chapters / Jump To Menu"
- 2 Disc Freeze & Make MC Unresponsive : American Beauty, and Priscilla Queen of the Desert
- 1 Disc says "Mismatch Between disc and player region codes.  See Disc packaging for details" : The Bank Job

While clearing Playback Info / Book Marks seems to have fixed my discs that Stall on Black Screen (well many UHD still do this), I still get a couple that ask if I want to resume playback from the last played (though they start from the begining).  These are "Beauty and the Beast" and "Big Hero 6". 

I'll grab dumps for American Beauty, and Priscilla Queen of the Desert.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #214 on: April 08, 2018, 05:12:46 am »

Arggg - American Beauty is now playing fine but Priscilla can still crash MC.  Crash Dump Here and MC logs attached.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #215 on: April 08, 2018, 10:48:08 pm »

This is cool.  Sidecar subs still work :) and are selectable by the MC OSD!  I've got a couple of non-english films I've had to add a sidecar english sub and figured it would only work in title mode but it still works in BD Menu mode.  These subs are also "remembered" between plays (but I guess that may change if Hendrik ignores the stream selection in the playback field). 

One Odd thing however is if you switch to Title Playback, all the subs are listed Twice (see pic).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #216 on: April 08, 2018, 10:52:49 pm »

It also raises an older discussion on the ability to manually tag (in Playback Info?) if you want a disc to start playback in Menu or Title mode.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #217 on: April 09, 2018, 02:04:45 am »

I've found something.  I'll need to test more but if there are values in "Playback Info" like "(1:2)(7:Streams)(6:0,4,23)(9:Subtitles)(0:)" then clearing them seems to make more discs play without issues.  '71 and 8 Mile now work.  I "think" also have a bookmark confuses some discs.  I'll clear both values and retest a bunch.

I've been looking into this, and I still have no idea how the presence of this alone would ever cause any issues. It just silently ignores them when the source filter doesn't expose the stream selection interface, and the BD source does not.
I've also tried to just set it on some discs and nothing happens.

Can you confirm that re-adding this causes the issues to return? Or maybe its the bookmark still, for some reason?
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #218 on: April 09, 2018, 02:42:15 am »

I'm wrong.  But I don't know what the issue is.....  Just tried playing '71 and 8 Mile since last nights test ... and both stalled (with no values in Bookmark and Playback Info).  Tried adding stuff / removing it from these fields did not help either.  Shutting down MC (and Server), restarted MC then both played fine, I could swap between Menu and Title Playback over and over without issues regardless if I had values in Bookmark and Playback Info.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #219 on: April 09, 2018, 03:03:01 am »

Rebooted my PC and now '71 and 8 Mile Freese again but the others play....
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #220 on: April 09, 2018, 03:05:28 am »

Shall I open you the window, or do you prefer throwing through it closed for dramatic effect?

Unfortunately I have no idea whats going on with those discs and since I really cannot reproduce any of that on any disc I have, also no point to start debugging at.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #221 on: April 09, 2018, 03:23:03 am »

Is profanity allowed on the Beta Board?
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #222 on: April 09, 2018, 04:46:48 am »

I'm stumped..... Tried removing progs, updating and resetting BIOS, updating nVidia Drivers, DrivePool drivers, rebooting, removing MC Plugins and re-downloading, trying differing Audio and Video Settings, and these two just stall. 

Apart from C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache, is there any other files being written or cached when BD Menus are being played?
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #223 on: April 09, 2018, 04:55:43 am »

There is some permanent storage in AppData\Roaming\bluray, its where discs store settings like your playback position for resuming etc.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #224 on: April 09, 2018, 05:08:13 am »

thanks - clearing that did not help (but at least I know where the resume stuff comes from on some discs).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #225 on: April 09, 2018, 05:17:14 am »

I don't get it.  When I play '71 as an example it looks as attached.  You can right click and bring up the MC Menu etc just fine, but the MC OSD will not appear when you press an Up Arrow.  The madVR stats update but it's like nothing is being decoded/rendered etc.

When are you next in Oz?  I owe you a drink anyway, how is Friday for you? :)
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #226 on: April 09, 2018, 05:28:27 am »

Heck! Just deleted the contents of C:\Users\natha\AppData\Roaming\bluray again and both '71 and 8 Mile Started working. 
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #227 on: April 09, 2018, 05:44:35 am »

Played a bunch in a row with '71 after each one.  All file till "13 Hours: The Secret Soldiers of Benghazi" which Hung MC (forced close), and after that '71 would stall on playback (but 13 Hours: The Secret Soldiers of Benghazi would then play fine). 

Back to square 1 : '71 and 8 Mile both stall again.  Rebooting and Deleting C:\Users\natha\AppData\Roaming\bluray is making no difference.

Does Java cache stuff somewhere?
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #228 on: April 09, 2018, 06:31:58 am »

One of my guesses is that part of the problem is that you ripped all your discs without the CERTIFICATE folder, because that folder is used to find the disc id, which in turn is used to determine the sub-path in those storage folders.
If the id cannot be determined, then its set to some default, which is the same for every disc - and maybe that causes conflicts?

I could try to disable permanent storage, and see if that makes it behave more predictably for you, but its not ideal to do that.

I don't actually know where exactly the MC Blu-ray ripping stuff is, maybe I should find it and include the CERTIFICATE folder.
Logged
~ nevcairiel
~ Author of LAV Filters

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71806
  • Where did I put my teeth?
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #229 on: April 09, 2018, 06:42:28 am »

Is profanity allowed on the Beta Board?
We'll have to send you a bar of soap so your wife can wash your mouth out with it.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #230 on: April 09, 2018, 06:48:58 am »

MC ripping has never copied the Certificate folder, only the contents of the BDMV Folder and the AnyDVD disc.inf file if that exists.  I just tried playing '71 of the original disc and it stalled.  I then copied the Certificate and ANY! (AnyDVD) to the folder with the rip and now both '71 and 8 Mile play fine.  Is it possible that without the Certificate folder there is some conflict as you play various disc???
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #231 on: April 09, 2018, 06:51:15 am »

FYI - Just checked the 8 Mile rip and it has the Certificate folder (must have ripped that one with AnyDVD not MC).
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #232 on: April 09, 2018, 06:51:48 am »

We'll have to send you a bar of soap so your wife can wash your mouth out with it.

Mmm what flavour?
Logged
JRiver CEO Elect

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71806
  • Where did I put my teeth?
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #233 on: April 09, 2018, 06:54:24 am »

Chocolate.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #234 on: April 09, 2018, 06:59:10 am »

That's me done for the next few days.  I'll have more of a play with Certificate folders when I'm back.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #235 on: April 10, 2018, 04:32:43 am »

As I think about this, should there be a change in MC's ripper to also copy the Certificate Folder?  If it is needed I guess I'll mount and copy this folder manually for all my rips (it will be a PITA for 1,000 odd discs but would not be to bad as these folders are not that big).
Thanks
Nathan
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #236 on: April 10, 2018, 04:43:20 am »

Already done for the next version, it'll now copy the entire disc, just in case. Everything next to the BDMV folder is tiny anyway, so no harm in preserving all of it.
I'm not 100% convinced that this is the real cause however, the behavior you're seeing is too erratic to make sense.
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #237 on: April 10, 2018, 05:01:02 am »

Thanks.... And erratic sums it up but there must be a pattern, I just need to find it
Logged
JRiver CEO Elect

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 4022
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #238 on: April 10, 2018, 05:50:48 am »

Thanks.... And erratic sums it up but there must be a pattern, I just need to find it
is it worth adding a list of discs confirmed to work (to this thread, to the wiki?) for reference purposes? might be useful in the initial period of this feature being publicly available
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #239 on: April 10, 2018, 06:05:33 am »

I don't like that. There are several versions of every movie which can be differently authored, and such a list quickly grows stale and may deter someone from even trying if his movie isn't on the list.
The number of discs that don't work should hopefully be reasonably low.
Logged
~ nevcairiel
~ Author of LAV Filters

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 4022
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #240 on: April 10, 2018, 07:27:43 am »

I don't like that. There are several versions of every movie which can be differently authored, and such a list quickly grows stale and may deter someone from even trying if his movie isn't on the list.
The number of discs that don't work should hopefully be reasonably low.
fair enough, is it worth logging the ones that are known not to work? with appropriate disclaimers about different versions of discs and so on?
Logged

SamuriHL

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1038
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #241 on: April 10, 2018, 10:25:13 am »

I still need to get back to testing, as well.  I reinstalled windows 10 recently and have not had a chance to test recent builds.  I did have a couple discs back when I first tested it that didn't work right so I'll retest them soon and post my results here.
Logged

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #242 on: April 10, 2018, 08:52:26 pm »

FYI - I've started keeping notes of what issues I'm seeing with what discs as it was driving me nuts (and still is).  Even in my case, it's only about 2% with playback issues and I think I've got some bizare edge case ....   A larger % (about 1/3rd) don't have Jump To/Chatpers exposed.  About 1/3rd of UHD stall (but these are not officially supported anyway).  If I can just work out what is causing the stall on some discs.... some of the time....
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #243 on: April 12, 2018, 02:20:14 am »

Back to testing.  '71 played fine when I was away.  Got back after a few days and '71 stills plays fine.  Updated the version of MC to 24.0.11 and '71 now stalls. No idea why.

Edit - here is the log.  This may be different to my previous logs as I've now added the Certificate folder to the rip.  I notice a couple of things:

Double Backslash in the JRE path: 0004266: 11876: Playback: CBDNavDemux::BDLog: libbluray/bdj/bdj.c:332: Opening C:\Users\natha\AppData\Roaming\J River\Media Center 24\Plugins\java64\\jre\bin\server\jvm

Odd Forward Slash in the black.png path: 0005703: 11956: Playback: CBDNavDemux::BDLog: java.awt.BDToolkit:0: ERROR: resource C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache\251153893997802\mount\00000\null\res/BLACK/Black.png does not exist but Black.png is in : C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache\251153893997802\VFSCache\BDMV\JAR\00001\res\BLACK

When it starts playing I'll grab the log and do a compare to see what looks different.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #244 on: April 12, 2018, 02:56:19 am »

...also (I don't think it matters) but I did a compare between my old '71 rip and original disc and noticed that MC did also not rip empty folder (eg in this case BDMV\AUXDATA and BDMV\Meta\ES and BDMV\META\TN)
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #245 on: April 12, 2018, 03:00:47 am »

Ok - Got '71 to work.  Played it and it was stalled but did a right click --> BD Menu (did nothing) --> Stop --> Return to MC --> Play again and it worked.  Log attached.  I'll compare the two logs after dinner.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #246 on: April 12, 2018, 03:52:57 am »

Hm yeah that missing file seems to be somehow related. In the working case it figured out where it is, in the non-working case it didn't.

ie.
CBDNavDemux::BDLog: org.videolan.VFSCache:0: INFO: using cached C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache\253379073798310\VFSCache\BDMV\JAR\00001\res\BLACK\Black.png
CBDNavDemux::BDLog: java.io.BDFileSystem:0: INFO: resolve(f): using cached C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache\253379073798310\VFSCache\BDMV\JAR\00001\res\BLACK\Black.png (\\MAIN\Media\Discs\'71\BDMV\JAR\00001\res\BLACK\Black.png)

vs.
CBDNavDemux::BDLog: java.io.BDFileSystem:0: INFO: resolve relative file null\res\BLACK\Black.png
CBDNavDemux::BDLog: java.awt.BDToolkit:0: ERROR: resource C:\Users\natha\AppData\Local\Temp\libbluray-bdj-cache\251153893997802\mount\00000\null\res/BLACK/Black.png does not exist
Logged
~ nevcairiel
~ Author of LAV Filters

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #247 on: April 12, 2018, 04:04:55 am »

Yeah that is what I'm reading as well from the logs.
Logged
JRiver CEO Elect

jmone

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 14323
  • I won! I won!
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #248 on: April 12, 2018, 04:13:11 am »

Upgraded again and '71 broke.  Log has \mount\00000\null\res/BLACK/Black.png does not exist again.  Lets see if I can get it to play again.
Logged
JRiver CEO Elect

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10814
Re: NEW: Blu-ray Menu Support (Beta)
« Reply #249 on: April 12, 2018, 04:14:05 am »

The big difference is the path:

\\MAIN\Media\Discs\'71\BDMV\JAR\00001\res\BLACK\Black.png
null\res\BLACK\Black.png

This is whats passed to the file loading function. In one case it knows where the disc is, in the other case that info is "null" and everything fails. Unfortunately I don't know where this string is being constructed, and without being able to reproduce it here, its going to be iffy.

I don't suppose you feel like uploading your copy of the disc, just to make sure? Perhaps without the big main movie m2ts, that should not be needed to get to the menu, afterall.
Logged
~ nevcairiel
~ Author of LAV Filters
Pages: 1 2 3 4 [5] 6 7 8 9   Go Up